summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit2e3b8b64deae0e76632be290b5741c38ba381a99 (patch)
tree5039b43c5f61983303f27baf181a426f899a62db
downloadaur-2e3b8b64deae0e76632be290b5741c38ba381a99.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--pipewalker.install8
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e043c6a5f406
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pipewalker
+ pkgdesc = Pieces of a computer network are to be turned, to make all computers connected to the same network
+ pkgver = 0.9.4
+ pkgrel = 1
+ url = http://pipewalker.sourceforge.net/
+ install = pipewalker.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = mesa
+ depends = sdl
+ depends = desktop-file-utils
+ source = http://downloads.sourceforge.net/pipewalker/pipewalker-0.9.4.tar.gz
+ sha256sums = d6d7717f1f333847cc4a2e9d83e97b971b3bfb539d99d4ae30a5140de6e386f4
+
+pkgname = pipewalker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38df0b32f6f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=pipewalker
+pkgver=0.9.4
+pkgrel=1
+pkgdesc="Pieces of a computer network are to be turned, to make all computers connected to the same network"
+arch=('i686' 'x86_64')
+url="http://pipewalker.sourceforge.net/"
+license=('GPL')
+depends=('mesa' 'sdl' 'desktop-file-utils')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('d6d7717f1f333847cc4a2e9d83e97b971b3bfb539d99d4ae30a5140de6e386f4')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+ make DESTDIR=${pkgdir} install
+
+ install -D -m644 ChangeLog ${pkgdir}/usr/share/doc/$pkgname/ChangeLog
+
+#removing unneeded
+ rm -rf ${pkgdir}/usr/share/menu
+}
diff --git a/pipewalker.install b/pipewalker.install
new file mode 100644
index 000000000000..1aeaf638f8fd
--- /dev/null
+++ b/pipewalker.install
@@ -0,0 +1,8 @@
+post_install() {
+ update-mime-database usr/share/mime > /dev/null
+ update-desktop-database -q
+}
+
+post_remove() {
+ post_install $1
+}