summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang-Huang Bao2022-01-17 12:33:43 +0800
committerHuang-Huang Bao2022-01-17 12:33:43 +0800
commit671d79842271711362bbf2db7b0e707add054525 (patch)
tree2dcf15abdadd33807a0066f44a884254cc0c9120
parent7968e1867c4c51c654ff29bfd879404d6d44d474 (diff)
downloadaur-671d79842271711362bbf2db7b0e707add054525.tar.gz
enable ROC modules
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 28 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7c8330e1b11..ba8e1832b83c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipewire-full-git
pkgdesc = Low-latency audio/video router and processor
- pkgver = 0.3.42.r26.g15ce86af
+ pkgver = 0.3.43.r68.g7c6649b5
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -32,6 +32,7 @@ pkgbase = pipewire-full-git
makedepends = vulkan-headers
makedepends = vulkan-icd-loader
makedepends = ffmpeg
+ makedepends = roc-toolkit
source = git+https://gitlab.freedesktop.org/pipewire/pipewire.git
sha256sums = SKIP
@@ -63,10 +64,11 @@ pkgname = pipewire-full-git
optdepends = pipewire-full-jack-client-git: JACK device/client
optdepends = pipewire-full-pulse-git: PulseAudio replacement
optdepends = pipewire-full-zeroconf-git: Zeroconf support
+ optdepends = pipewire-full-roc-git: ROC support
optdepends = gst-plugin-pipewire-full-git: GStreamer support
optdepends = ofono: ofono Bluetooth HFP support
optdepends = hsphfpd: hsphfpd Bluetooth HSP/HFP support
- provides = pipewire=0.3.42.r26.g15ce86af
+ provides = pipewire=0.3.43.r68.g7c6649b5
provides = alsa-card-profiles
provides = libpipewire-0.3.so
conflicts = pipewire
@@ -161,3 +163,10 @@ pkgname = pipewire-full-ffmpeg-git
depends = libavformat.so
provides = pipewire-ffmpeg
conflicts = pipewire-ffmpeg
+
+pkgname = pipewire-full-roc-git
+ pkgdesc = Low-latency audio/video router and processor - ROC support
+ depends = pipewire-full-git
+ depends = roc-toolkit
+ provides = pipewire-roc
+ conflicts = pipewire-roc
diff --git a/PKGBUILD b/PKGBUILD
index 4c68323170b8..a1cafa896d48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,9 @@ pkgname=(pipewire-full-git
pipewire-full-jack-client-git
pipewire-full-vulkan-git
pipewire-full-ffmpeg-git
+ pipewire-full-roc-git
)
-pkgver=0.3.42.r26.g15ce86af
+pkgver=0.3.43.r68.g7c6649b5
pkgrel=1
pkgdesc="Low-latency audio/video router and processor"
url="https://pipewire.org"
@@ -32,6 +33,7 @@ makedepends=(git meson doxygen python-docutils graphviz ncurses
jack2
vulkan-headers vulkan-icd-loader
ffmpeg
+ roc-toolkit
)
source=("git+https://gitlab.freedesktop.org/pipewire/${_pkgbase}.git")
sha256sums=('SKIP')
@@ -49,7 +51,6 @@ build() {
-D test=enabled \
-D libcamera=disabled \
-D sdl2=disabled \
- -D roc=disabled \
-D session-managers=[] \
-D vulkan=enabled \
-D ffmpeg=enabled \
@@ -88,6 +89,7 @@ package_pipewire-full-git() {
'pipewire-full-jack-client-git: JACK device/client'
'pipewire-full-pulse-git: PulseAudio replacement'
'pipewire-full-zeroconf-git: Zeroconf support'
+ 'pipewire-full-roc-git: ROC support'
'gst-plugin-pipewire-full-git: GStreamer support'
'ofono: ofono Bluetooth HFP support'
'hsphfpd: hsphfpd Bluetooth HSP/HFP support')
@@ -127,6 +129,8 @@ package_pipewire-full-git() {
_pick vulkan usr/lib/spa-0.2/vulkan
_pick ffmpeg usr/lib/spa-0.2/ffmpeg
+
+ _pick roc usr/lib/pipewire-$_ver/libpipewire-module-roc-{sink,source}.so
}
package_pipewire-full-docs-git() {
@@ -257,3 +261,14 @@ package_pipewire-full-ffmpeg-git() {
install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 $_pkgbase/COPYING
}
+
+package_pipewire-full-roc-git() {
+ pkgdesc+=" - ROC support"
+ depends=(pipewire-full-git roc-toolkit)
+ provides=(pipewire-roc)
+ conflicts=(pipewire-roc)
+
+ mv roc/* "${pkgdir}"
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 $_pkgbase/COPYING
+}