summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuang-Huang2021-02-14 13:02:35 +0800
committerHuang-Huang2021-02-14 13:02:35 +0800
commite6398e1adcbaf665a4c40f1c43c4e441c3cb24ae (patch)
treed035cfa1caf621a861f864c72a2d56707f020441
parent4ddb5c26e581c2ac9f9a37a2d035b1f29d253cfe (diff)
downloadaur-e6398e1adcbaf665a4c40f1c43c4e441c3cb24ae.tar.gz
Bump
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a63ce7ecf1e..9fd5bda68f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipewire-full-git
pkgdesc = Server and user space API to deal with multimedia pipelines
- pkgver = 0.3.21.r89.g0855b1bb
+ pkgver = 0.3.21.r110.g373fd53d
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -10,10 +10,9 @@ pkgbase = pipewire-full-git
makedepends = doxygen
makedepends = graphviz
makedepends = xmltoman
- makedepends = valgrind
makedepends = jack2
makedepends = alsa-lib
- makedepends = gst-plugins-base
+ makedepends = gst-plugins-base-libs
makedepends = sbc
makedepends = rtkit
makedepends = vulkan-icd-loader
@@ -32,7 +31,6 @@ pkgbase = pipewire-full-git
pkgname = pipewire-full-git
install = pipewire.install
- depends = sbc
depends = rtkit
depends = libdbus-1.so
depends = libncursesw.so
@@ -71,6 +69,7 @@ pkgname = pipewire-full-jack-git
pkgdesc = Server and user space API to deal with multimedia pipelines (JACK support)
depends = pipewire-full-git
depends = libpipewire-0.3.so
+ depends = bash
depends = libjack.so
provides = pipewire-jack
conflicts = pipewire-jack
@@ -126,6 +125,8 @@ pkgname = pipewire-full-bluez5-git
depends = pipewire-full-git
depends = libpipewire-0.3.so
depends = bluez-libs
+ depends = sbc
+ depends = libdbus-1.so
depends = libldacBT_enc.so
depends = libopenaptx.so
depends = libfdk-aac.so
@@ -138,7 +139,9 @@ pkgname = pipewire-full-bluez5-hsphfpd-git
depends = pipewire-full-git
depends = libpipewire-0.3.so
depends = bluez-libs
+ depends = sbc
depends = hsphfpd
+ depends = libdbus-1.so
depends = libldacBT_enc.so
depends = libopenaptx.so
depends = libfdk-aac.so
diff --git a/PKGBUILD b/PKGBUILD
index ada221a3cd1..4b2c536f1c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,16 @@ pkgname=(pipewire-full-git pipewire-full-docs-git pipewire-full-jack-git
gst-plugin-pipewire-full-git
pipewire-full-vulkan-git pipewire-full-ffmpeg-git
pipewire-full-bluez5-git pipewire-full-bluez5-hsphfpd-git)
-pkgver=0.3.21.r89.g0855b1bb
+pkgver=0.3.21.r110.g373fd53d
pkgrel=1
pkgdesc="Server and user space API to deal with multimedia pipelines"
url="https://pipewire.org"
license=(MIT)
arch=(x86_64)
-makedepends=(git meson doxygen graphviz xmltoman valgrind jack2
- alsa-lib gst-plugins-base sbc rtkit vulkan-icd-loader dbus sdl2
- ncurses libsndfile bluez-libs vulkan-headers libldac libopenaptx
- libfdk-aac ffmpeg)
+makedepends=(git meson doxygen graphviz xmltoman jack2
+ alsa-lib gst-plugins-base-libs sbc rtkit vulkan-icd-loader dbus
+ sdl2 ncurses libsndfile bluez-libs vulkan-headers libldac
+ libopenaptx libfdk-aac ffmpeg)
source=("git+https://gitlab.freedesktop.org/pipewire/pipewire.git")
sha256sums=('SKIP')
@@ -63,7 +63,7 @@ _pick() {
_ver=${pkgver:0:3}
package_pipewire-full-git() {
- depends=(sbc rtkit
+ depends=(rtkit
libdbus-1.so libncursesw.so libsndfile.so libudev.so libasound.so
libsystemd.so)
optdepends=('pipewire-full-docs-git: Documentation'
@@ -130,7 +130,7 @@ package_pipewire-full-docs-git() {
package_pipewire-full-jack-git() {
pkgdesc+=" (JACK support)"
- depends=(pipewire-full-git libpipewire-$_ver.so libjack.so)
+ depends=(pipewire-full-git libpipewire-$_ver.so bash libjack.so)
provides=(pipewire-jack)
conflicts=(pipewire-jack)
mv jack/* "$pkgdir"
@@ -183,8 +183,8 @@ package_pipewire-full-ffmpeg-git() {
package_pipewire-full-bluez5-git() {
pkgdesc+=" (BlueZ 5 SPA plugin)"
- depends=(pipewire-full-git libpipewire-$_ver.so bluez-libs
- libldacBT_enc.so libopenaptx.so libfdk-aac.so)
+ depends=(pipewire-full-git libpipewire-$_ver.so bluez-libs sbc
+ libdbus-1.so libldacBT_enc.so libopenaptx.so libfdk-aac.so)
optdepends=('ofono: HFP support')
provides=(pipewire-bluez5)
conflicts=(pipewire-bluez5)
@@ -193,8 +193,8 @@ package_pipewire-full-bluez5-git() {
package_pipewire-full-bluez5-hsphfpd-git() {
pkgdesc+=" (BlueZ 5 SPA plugin, using hsphfpd for HSP/HFP support)"
- depends=(pipewire-full-git libpipewire-$_ver.so bluez-libs hsphfpd
- libldacBT_enc.so libopenaptx.so libfdk-aac.so)
+ depends=(pipewire-full-git libpipewire-$_ver.so bluez-libs sbc hsphfpd
+ libdbus-1.so libldacBT_enc.so libopenaptx.so libfdk-aac.so)
provides=(pipewire-bluez5)
conflicts=(pipewire-bluez5)
mv bluez5-hsphfpd/* "${pkgdir}"