summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-30 10:51:27 +0200
committersL1pKn072020-03-30 10:54:05 +0200
commit3f6273742751ed3f5eec6b1a207098e697240fa5 (patch)
tree6919346dfe0e991742d9fb5b3d6502dcb0033cc4
parent10b3fd4af8e8c8baeadb939aa03f414c780449fc (diff)
downloadaur-3f6273742751ed3f5eec6b1a207098e697240fa5.tar.gz
bump, make split packages
-rw-r--r--.SRCINFO56
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD111
-rw-r--r--pipewire-git.install14
4 files changed, 166 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 750cdd9bf394..c2aebcfe0517 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipewire-git
- pkgdesc = Multimedia processing graphs. (GIT version)
- pkgver = 0.3.0.42.gb7dbf4bb
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (GIT version)
+ pkgver = 0.3.2.11.ge00c0ffd
pkgrel = 1
url = https://pipewire.org
arch = x86_64
@@ -12,16 +12,60 @@ pkgbase = pipewire-git
makedepends = meson
makedepends = valgrind
makedepends = vulkan-headers
- depends = ffmpeg
+ makedepends = jack2
+ makedepends = sbc
+ depends = rtkit
depends = sbc
- depends = vulkan-icd-loader
depends = bluez-libs
- depends = jack2
- provides = pipewire
+ depends = vulkan-icd-loader
+ depends = ffmpeg
+ depends = libpulse.so
+ depends = libdbus-1.so
+ depends = libsndfile.so
conflicts = pipewire
+ conflicts = pipewire-pulse
+ conflicts = pipewire-jack
+ conflicts = pipewire-docs
backup = etc/pipewire/pipewire.conf
source = git+https://gitlab.freedesktop.org/pipewire/pipewire.git
sha256sums = SKIP
pkgname = pipewire-git
+ install = pipewire-git.install
+ depends = ffmpeg
+ depends = sbc
+ depends = rtkit
+ depends = vulkan-icd-loader
+ depends = bluez-libs
+ depends = libdbus-1.so
+ depends = libsndfile.so
+ optdepends = pipewire-docs: Documentation
+ optdepends = pipewire-jack: JACK support
+ optdepends = pipewire-pulse: PulseAudio support
+ provides = libpipewire-0.3.so
+ backup = etc/pipewire/pipewire.conf
+
+pkgname = pipewire-docs-git
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (documentation)(GIT Version)
+ provides = pipewire-dics
+ conflicts = pipewire-docs
+
+pkgname = pipewire-jack-git
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (JACK support)(GIT Version)
+ depends = libpipewire-0.3.so
+ depends = libjack.so
+ provides = libjack-pw.so
+ provides = pipewire-jack
+ conflicts = pipewire-jack
+
+pkgname = pipewire-pulse-git
+ pkgdesc = Server and user space API to deal with multimedia pipelines. (Pulse support)(GIT version)
+ depends = libpipewire-0.3.so
+ depends = libpulse.so
+ depends = libglib-2.0.so
+ provides = pipewire-pulse
+ provides = libpulse-pw.so
+ provides = libpulse-simple-pw.so
+ provides = libpulse-mainloop-glib-pw.so
+ conflicts = pipewire-pulse
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..a8c0ac10ddea 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!pipewire-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 8e8a79a8c896..f1c425de59c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,23 @@
-pkgname=pipewire-git
-pkgver=0.3.0.42.gb7dbf4bb
+pkgbase=pipewire-git
+pkgname=('pipewire-git'
+ 'pipewire-docs-git'
+ 'pipewire-jack-git'
+ 'pipewire-pulse-git'
+ )
+pkgver=0.3.2.11.ge00c0ffd
pkgrel=1
-pkgdesc="Multimedia processing graphs. (GIT version)"
+pkgdesc='Server and user space API to deal with multimedia pipelines. (GIT version)'
arch=('x86_64')
url='https://pipewire.org'
license=('LGPL')
-depends=('ffmpeg'
+depends=('rtkit'
'sbc'
- 'vulkan-icd-loader'
'bluez-libs'
- 'jack2'
+ 'vulkan-icd-loader'
+ 'ffmpeg'
+ 'libpulse.so'
+ 'libdbus-1.so'
+ 'libsndfile.so'
)
makedepends=('graphviz'
'doxygen'
@@ -18,9 +26,14 @@ makedepends=('graphviz'
'meson'
'valgrind'
'vulkan-headers'
+ 'jack2'
+ 'sbc'
)
-conflicts=('pipewire')
-provides=('pipewire')
+conflicts=('pipewire'
+ 'pipewire-pulse'
+ 'pipewire-jack'
+ 'pipewire-docs'
+ )
source=('git+https://gitlab.freedesktop.org/pipewire/pipewire.git')
sha256sums=('SKIP')
backup=('etc/pipewire/pipewire.conf')
@@ -43,6 +56,8 @@ prepare() {
build() {
cd "${srcdir}/build"
+ CFLAGS+=" -Wformat"
+
arch-meson ../pipewire \
-D docs=true \
-D gstreamer=false \
@@ -51,6 +66,82 @@ build() {
ninja
}
-package() {
- DESTDIR="${pkgdir}" ninja -C build install
+check() {
+ meson test -C build --print-errorlogs
+}
+
+_pick() {
+ local p="${1}" f d; shift
+ for f; do
+ d="${srcdir}/${p}/${f#$pkgdir/}"
+ mkdir -p "$(dirname "${d}")"
+ mv "${f}" "${d}"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "${f}")"
+ done
+}
+
+package_pipewire-git() {
+ depends=('ffmpeg'
+ 'sbc'
+ 'rtkit'
+ 'vulkan-icd-loader'
+ 'bluez-libs'
+ 'libdbus-1.so'
+ 'libsndfile.so'
+ )
+ optdepends=('pipewire-docs: Documentation'
+ 'pipewire-jack: JACK support'
+ 'pipewire-pulse: PulseAudio support'
+ )
+ provides=("libpipewire-${pkgver:0:3}.so")
+ backup=('etc/pipewire/pipewire.conf')
+ install=pipewire.install
+
+ DESTDIR="${pkgdir}" meson install -C build
+
+ cd "${pkgdir}"
+
+ _pick docs usr/share/doc
+
+ _pick pulse usr/lib/libpulse*
+
+ _pick jack usr/lib/spa-0.2/jack
+ _pick jack usr/lib/libjack*
+}
+
+package_pipewire-docs-git() {
+ pkgdesc='Server and user space API to deal with multimedia pipelines. (documentation)(GIT Version)'
+ provides=('pipewire-dics')
+ conflicts=('pipewire-docs')
+
+ mv docs/* "${pkgdir}"
+}
+
+package_pipewire-jack-git() {
+ pkgdesc='Server and user space API to deal with multimedia pipelines. (JACK support)(GIT Version)'
+ depends=("libpipewire-${pkgver:0:3}.so"
+ 'libjack.so'
+ )
+ provides=('libjack-pw.so'
+ 'pipewire-jack'
+ )
+ conflicts=('pipewire-jack')
+
+ mv jack/* "${pkgdir}"
+}
+
+package_pipewire-pulse-git() {
+ pkgdesc='Server and user space API to deal with multimedia pipelines. (Pulse support)(GIT version)'
+ depends=("libpipewire-${pkgver:0:3}.so"
+ 'libpulse.so'
+ 'libglib-2.0.so'
+ )
+ provides=('pipewire-pulse'
+ 'libpulse-pw.so'
+ 'libpulse-simple-pw.so'
+ 'libpulse-mainloop-glib-pw.so'
+ )
+ conflicts=('pipewire-pulse')
+
+ mv pulse/* "${pkgdir}"
}
diff --git a/pipewire-git.install b/pipewire-git.install
new file mode 100644
index 000000000000..416e5ed97a1d
--- /dev/null
+++ b/pipewire-git.install
@@ -0,0 +1,14 @@
+post_install() {
+ # Enable socket by default
+ systemctl --global enable pipewire.socket
+}
+
+post_upgrade() {
+ if (( $(vercmp $2 0.1.6-2) < 0)); then
+ systemctl --global enable pipewire.socket
+ fi
+}
+
+pre_remove() {
+ systemctl --global disable pipewire.socket
+}