summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-08-11 08:37:52 -0600
committerMark Wagie2023-08-11 08:37:52 -0600
commitcafc9df275fc0f7ae49da05290726d5feaef029a (patch)
tree9d86ed61762bd20bac5ee8691a90c04c1c5dc33a
parentf9e0eee3db4075f92b984fc677c0bcc160cde85c (diff)
downloadaur-cafc9df275fc0f7ae49da05290726d5feaef029a.tar.gz
0.10.6
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4427d8488688..58800ff6d772 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pipgrip
pkgdesc = Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm
- pkgver = 0.10.5
+ pkgver = 0.10.6
pkgrel = 1
url = https://github.com/ddelange/pipgrip
arch = any
@@ -12,10 +12,9 @@ pkgbase = pipgrip
depends = python-click
depends = python-packaging
depends = python-pip
- depends = python-pkginfo
depends = python-setuptools
depends = python-wheel
- source = https://files.pythonhosted.org/packages/source/p/pipgrip/pipgrip-0.10.5.tar.gz
- sha256sums = dba22c035439ee7942ff2989c33de7ce5247519dcef81bd9dd5042d3b35db3d3
+ source = https://files.pythonhosted.org/packages/source/p/pipgrip/pipgrip-0.10.6.tar.gz
+ sha256sums = 70db48889bbe31c8866264f42e7d553b33d638e76654d0b6fe151a83990db831
pkgname = pipgrip
diff --git a/PKGBUILD b/PKGBUILD
index dd5bdc87e202..e11b4cd3dd0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=pipgrip
-pkgver=0.10.5
+pkgver=0.10.6
pkgrel=1
pkgdesc="Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm"
arch=('any')
url="https://github.com/ddelange/pipgrip"
license=('BSD')
depends=('python-anytree' 'python-click' 'python-packaging' 'python-pip'
- 'python-pkginfo' 'python-setuptools' 'python-wheel')
+ 'python-setuptools' 'python-wheel')
makedepends=('python-build' 'python-installer' 'python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('dba22c035439ee7942ff2989c33de7ce5247519dcef81bd9dd5042d3b35db3d3')
+sha256sums=('70db48889bbe31c8866264f42e7d553b33d638e76654d0b6fe151a83990db831')
prepare() {
cd "$pkgname-$pkgver"
# Relax requirements
- sed -i 's/pkginfo>=1.4.2,<1.8/pkginfo>=1.4.2/g' requirements/prod.txt
sed -i 's/setuptools_scm<7/setuptools_scm/g' setup.py
}