summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 09:22:15 -0600
committerMark Wagie2022-04-15 09:22:15 -0600
commitd65704692881df13e35d4bd6afa0f49a29033f22 (patch)
tree7a98a036dd711b690f27439674572e9250f70c57
parenta4defa6e9b094634fd3e55bdf3678939995be415 (diff)
downloadaur-d65704692881df13e35d4bd6afa0f49a29033f22.tar.gz
standards based build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6d08666b119..55c64852c0ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = pipgrip
pkgdesc = Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm
pkgver = 0.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ddelange/pipgrip
arch = any
license = BSD
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools-scm
depends = python-anytree
depends = python-click
diff --git a/PKGBUILD b/PKGBUILD
index 4001a2de63d5..15334e256b6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=pipgrip
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight pip dependency resolver with deptree preview functionality based on the PubGrub algorithm"
arch=('any')
url="https://github.com/ddelange/pipgrip"
license=('BSD')
depends=('python-anytree' 'python-click' 'python-pip' 'python-packaging' 'python-pkginfo'
'python-setuptools' 'python-wheel')
-makedepends=('python-setuptools-scm')
+makedepends=('python-build' 'python-installer' 'python-setuptools-scm')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('2ecf32bc30d245145de5ae0f4ea6b7e3e1ae2deff7b6317931a4a470185560d4')
@@ -21,12 +21,12 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}