summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorelkowar2020-04-18 13:08:26 +0200
committerelkowar2020-04-18 13:08:26 +0200
commitb9b6e23dd0a772637aa34163b2cd4320bd510bf5 (patch)
tree91253f27cc426ad77cb03df2eac4fb80fd2c52ba
downloadaur-b9b6e23dd0a772637aa34163b2cd4320bd510bf5.tar.gz
initialize default project
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cab13b10ee00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pipr-git
+ pkgdesc = A commandline-utility to interactively build complex shell pipelines
+ pkgver = r66.2ca7327
+ pkgrel = 1
+ url = https://gitlab.com/Elkowar/pipr
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ depends = gcc-libs
+ optdepends = bubblewrap: run commands in isolation. STRONGLY RECOMMENDED!
+ source = pipr-git::git+https://gitlab.com/Elkowar/pipr.git
+ md5sums = SKIP
+
+pkgname = pipr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5afb08debcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Leon Kowarschick <lkowarschick at gmail dot com>
+pkgname=pipr-git
+pkgver=r66.2ca7327
+pkgrel=1
+makedepends=('rust' 'cargo' 'git')
+depends=('gcc-libs')
+optdepends=('bubblewrap: run commands in isolation. STRONGLY RECOMMENDED!')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgdesc="A commandline-utility to interactively build complex shell pipelines"
+license=('MIT')
+source=('pipr-git::git+https://gitlab.com/Elkowar/pipr.git')
+url="https://gitlab.com/Elkowar/pipr"
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/pipr-git"
+ cargo build --release --locked --all-features
+}
+
+package() {
+ cd "$srcdir/pipr-git"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 755 target/release/pipr -t "${pkgdir}/usr/bin"
+}