summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2024-03-29 15:11:41 +1000
committerMark Blakeney2024-03-29 15:11:41 +1000
commit13c1cc9771a9a5107f891dd2e05992b2b0b18940 (patch)
tree28312cc1378792c76d1701d4be91258c34a472cd
downloadaur-13c1cc9771a9a5107f891dd2e05992b2b0b18940.tar.gz
Initial version 1.0
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..662e165b4320
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pipxu
+ pkgdesc = Install and Run Python Applications in Isolated Environments using UV
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/bulletmark/pipxu
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools-scm
+ depends = python>=3.8
+ depends = python-filelock
+ depends = python-platformdirs
+ depends = uv
+ source = pipxu-1.0.tar.gz::https://github.com/bulletmark/pipxu/archive/1.0.tar.gz
+ sha1sums = f0e7804b5c2f14ff1fbacbebb6489f42e74d8eee
+
+pkgname = pipxu
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad6fbda9f142
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.tar
+*.tar.*
+*.[gx]z
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb82f482657a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: mark.blakeney at bullet-systems dot net
+pkgname=pipxu
+pkgver=1.0
+pkgrel=1
+pkgdesc="Install and Run Python Applications in Isolated Environments using UV"
+url="https://github.com/bulletmark/$pkgname"
+license=(GPL3)
+arch=(any)
+depends=("python>=3.8" "python-filelock" "python-platformdirs" "uv")
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha1sums=('f0e7804b5c2f14ff1fbacbebb6489f42e74d8eee')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+
+# vim:set ts=2 sw=2 et: