summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJörg Müller2016-04-25 12:06:06 +0200
committerJörg Müller2016-04-25 12:06:06 +0200
commit7c0f147b301dbaba0854200a912f9a932cf45dbc (patch)
treef0a97b7cea3c701c649c41502446294fed738220
downloadaur-piranha-git.tar.gz
Initial version.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a4acf0b04cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = piranha-git
+ pkgdesc = Piranha is a C++11-based computer algebra library for the manipulation of algebraic objects, such as polynomials and Poisson series, commonly encountered in celestial mechanics.
+ pkgver = 0.1.3524.c99d233
+ pkgrel = 1
+ url = https://github.com/bluescarni/piranha
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = gcc
+ makedepends = cmake
+ makedepends = git
+ depends = python
+ depends = boost
+ depends = gmp
+ depends = mpfr
+ depends = bzip2
+ source = git+https://github.com/bluescarni/piranha.git
+ md5sums = SKIP
+
+pkgname = piranha-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59754bc061e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: neXyon <nexyon at gmail dot com>
+
+pkgname=piranha-git
+pkgver=0.1.3524.c99d233
+pkgrel=1
+pkgdesc="Piranha is a C++11-based computer algebra library for the manipulation of algebraic objects, such as polynomials and Poisson series, commonly encountered in celestial mechanics."
+arch=('i686' 'x86_64')
+url="https://github.com/bluescarni/piranha"
+license=('LGPL3')
+groups=()
+depends=('python' 'boost' 'gmp' 'mpfr' 'bzip2')
+makedepends=('gcc' 'cmake' 'git')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("git+https://github.com/bluescarni/piranha.git")
+md5sums=('SKIP')
+noextract=()
+_gitname="piranha"
+
+pkgver() {
+ cd $_gitname
+
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+
+ echo 0.1.$revision.$hash
+}
+
+build() {
+ mkdir -p build
+ cd build
+
+ cmake ../$_gitname \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DBUILD_PYRANHA=ON \
+ -DBUILD_TESTS=OFF || return 1
+
+ make $MAKEFLAGS || return 1
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install || return 1
+}
+