summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Stanchev2015-06-11 13:36:32 -0400
committerViktor Stanchev2015-06-11 13:36:32 -0400
commit77b3201774c6174333d8f17eba4a2d417af6c5b0 (patch)
tree0fb425519689100b6ed81113f0dc84194d1b5f98
downloadaur-77b3201774c6174333d8f17eba4a2d417af6c5b0.tar.gz
initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba2219106401
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pirate-get
+ pkgdesc = A command line interface for the Pirate Bay
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/vikstrous/pirate-get/
+ arch = any
+ license = AGPL
+ depends = python
+ optdepends = python-colorama: for colored output
+ source = https://github.com/vikstrous/pirate-get/archive/v0.2.4.tar.gz
+ sha256sums = 17f26e015e15afd280123b173678566b19879fe61fdaf53fd7676461308ad006
+
+pkgname = pirate-get
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7498ea4be851
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Viktor Stanchev <me aatt viktorstanchev doot com>
+
+pkgname=pirate-get
+pkgver=0.2.4
+pkgrel=1
+pkgdesc='A command line interface for the Pirate Bay'
+arch=('any')
+url='https://github.com/vikstrous/pirate-get/'
+license=('AGPL')
+depends=('python')
+optdepends=('python-colorama: for colored output')
+source=('https://github.com/vikstrous/pirate-get/archive/v'${pkgver}'.tar.gz')
+sha256sums=('17f26e015e15afd280123b173678566b19879fe61fdaf53fd7676461308ad006')
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin/
+ cp ${pkgname}-${pkgver}/${pkgname}.py ${pkgdir}/usr/bin/${pkgname}
+}
+
+check() {
+ stat ${pkgname}-${pkgver}/${pkgname}.py
+}