summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhuangzhuang2023-01-21 21:15:05 +0800
committerzhuangzhuang2023-01-21 21:15:05 +0800
commitd2f0a4ecdb8640e01755b943697c65c879b98332 (patch)
tree588e5dc4d8c19b021832b49e484dc68655c32248
parent07d95ca20c8fe1f4a50415f5970da07bc627b711 (diff)
downloadaur-d2f0a4ecdb8640e01755b943697c65c879b98332.tar.gz
first
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD2
2 files changed, 22 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21d16d0a8fcd..395a09b61bf1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,3 +19,24 @@ pkgbase = piscesys-fishui-git
sha512sums = SKIP
pkgname = piscesys-fishui-git
+pkgbase = piscesys-fishui-git
+ pkgdesc = GUI library based on QQC2 for Piscesys applications
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://gitlab.com/piscesys/fishui
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ depends = kwindowsystem
+ depends = qt5-declarative
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols2
+ provides = fishui
+ conflicts = fishui
+ conflicts = fishui-git
+ source = git+https://gitlab.com/piscesys/fishui.git
+ sha512sums = SKIP
+
+pkgname = piscesys-fishui-git
diff --git a/PKGBUILD b/PKGBUILD
index 2bfac57ff328..27679b243043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ pkgver() {
build() {
cd $_pkgname
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
make
}