summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhuangzhuang2023-01-21 19:58:38 +0800
committerzhuangzhuang2023-01-21 19:58:38 +0800
commitf248f8dbcd37a51f7346217adced4c4eb13edb1b (patch)
tree8b7b81876bf5f2d99a0d1dcb00ff941665487d79
downloadaur-f248f8dbcd37a51f7346217adced4c4eb13edb1b.tar.gz
first
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aad9bbc3a9d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = piscesys-fishui-git
+ pkgdesc = GUI library based on QQC2 for Piscesys applications
+ pkgver = 0.9
+ pkgrel = 1
+ url = https://gitlab.com/piscesys/fishui
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ depends = kwindowsystem
+ depends = qt5-declarative
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols2
+ provides = fishui
+ conflicts = fishui
+ source = git+https://gitlab.com/piscesys/fishui.git
+ sha512sums = SKIP
+
+pkgname = piscesys-fishui-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bbd4ded2940b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: zhuangzhuang <xufengyuan20080802@outlook.com>
+pkgname=piscesys-fishui-git
+_pkgname=fishui
+pkgver=0.9
+pkgrel=1
+pkgdesc="GUI library based on QQC2 for Piscesys applications"
+arch=('x86_64')
+url="https://gitlab.com/piscesys/fishui"
+license=('GPL')
+depends=('kwindowsystem' 'qt5-declarative' 'qt5-graphicaleffects' 'qt5-quickcontrols2')
+makedepends=('git' 'extra-cmake-modules' 'qt5-tools')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $_pkgname
+
+ cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $_pkgname
+
+ DESTDIR="$pkgdir"
+ make install
+}