summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuttley2019-06-26 11:29:14 +0200
committerMartchus2019-06-26 11:30:10 +0200
commit06b85e93340e50de1e1808d46b060095a5114889 (patch)
tree1f00ce11842bbe8c30f2ebfb9e614a89fed46c30
parentabca7369558053315a0cc7ecb83176a2a0c5f0e0 (diff)
downloadaur-06b85e93340e50de1e1808d46b060095a5114889.tar.gz
pistache: move lib64/ to lib/
/usr/lib64/ is owned by 'filesystem' package also removed unnecessary comment, now library builds shared library by default
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ba11b54bbfe..a67b2202f5e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pistache-git
pkgdesc = Modern and elegant HTTP and REST framework for C++
- pkgver = 223.7184600
+ pkgver = 985.c5927e1
pkgrel = 1
url = https://github.com/oktal/pistache
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 617d642889bf..eb2f20dbf6c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pistache-git
_name=${pkgname%-git}
-pkgver=223.7184600
+pkgver=985.c5927e1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Modern and elegant HTTP and REST framework for C++'
@@ -26,9 +26,6 @@ pkgver() {
build() {
cd "${srcdir}/${_name}"
- # since this is only a small lib and ABI seems very unstable at this point
- # it should be ok to build it only as a static lib for now
-
cmake \
-DCMAKE_BUILD_TYPE=Release \
-DPISTACHE_BUILD_TESTS=true \
@@ -44,4 +41,5 @@ check() {
package() {
cd "${srcdir}/${_name}"
make DESTDIR="${pkgdir}" install
+ mv ${pkgdir}/usr/lib{64,}
}