summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamega7Cattac2021-10-11 12:52:20 +0200
committerMartchus2021-10-11 12:52:20 +0200
commitb9c4a487a1e27434f6924687a195978d40eaa4ff (patch)
tree3b3f40fd62f82dac2f250c439b06915cff1b4ecb
parent56ef0260e2342858baf3b0ffb25cc1d924fe807f (diff)
downloadaur-b9c4a487a1e27434f6924687a195978d40eaa4ff.tar.gz
Update sources and compilation method
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8a4b924ae35..cf6e28dcad7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = pistache-git
pkgdesc = Modern and elegant HTTP and REST framework for C++
- pkgver = 1047.0c21c85
+ pkgver = 1534.ff9db0d
pkgrel = 1
- url = https://github.com/oktal/pistache
+ url = https://github.com/pistacheio/pistache
arch = i686
arch = x86_64
license = APACHE
checkdepends = gtest
- makedepends = cmake
+ makedepends = meson
makedepends = git
provides = pistache
conflicts = pistache
options = staticlibs
- source = pistache::git://github.com/oktal/pistache.git
+ source = git+https://github.com/pistacheio/pistache.git
sha256sums = SKIP
pkgname = pistache-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8913f5474646..d453a210b6c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,19 @@
pkgname=pistache-git
_name=${pkgname%-git}
-pkgver=1047.0c21c85
+pkgver=1534.ff9db0d
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='Modern and elegant HTTP and REST framework for C++'
license=('APACHE')
depends=()
-makedepends=('cmake' 'git')
+makedepends=('meson' 'git')
checkdepends=('gtest')
provides=("${_name}")
conflicts=("${_name}")
options=(staticlibs)
-url="https://github.com/oktal/${_name}"
-source=("${_name}::git://github.com/oktal/${_name}.git")
+url="https://github.com/pistacheio/${_name}"
+source=("git+https://github.com/pistacheio/${_name}.git")
sha256sums=('SKIP')
pkgver() {
@@ -28,21 +28,21 @@ pkgver() {
build() {
cd "${srcdir}/${_name}"
- cmake \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DPISTACHE_BUILD_TESTS=true \
+ meson setup build \
+ --buildtype=release \
-DPISTACHE_USE_SSL=true \
- .
- make
+ -DPISTACHE_BUILD_EXAMPLES=true \
+ -DPISTACHE_BUILD_TESTS=true \
+ -DPISTACHE_BUILD_DOCS=false
+ meson compile -C build
}
check() {
cd "${srcdir}/${_name}"
- make test
+ meson test -C build
}
package() {
cd "${srcdir}/${_name}"
- make DESTDIR="${pkgdir}" install
+ meson install -C build
}