summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsharethewisdom2019-11-25 15:52:26 +0100
committersharethewisdom2019-11-25 15:52:26 +0100
commit1a53a138a4eb86ece2feb30cbc2250427ad23535 (patch)
treef391433e283e2cc6955c742dc7f8f71dc0ea364e
parent5bb65134bf3eba4093bbf25e0cc656ccadb1514c (diff)
downloadaur-1a53a138a4eb86ece2feb30cbc2250427ad23535.tar.gz
fixed permissions problem when makepkg tries to remove $srcdir
-rw-r--r--PKGBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a228eafff51f..c6e61ff9f939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,10 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ chmod -R a+wX "$srcdir/$pkgname"
+}
+
build() {
cd "$srcdir/$pkgname"
# -fix flag is a no-op when using modules