summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsharethewisdom2019-11-25 15:59:11 +0100
committersharethewisdom2019-11-25 15:59:11 +0100
commit5a9b5ae3e2301a7f72299969192061e95d904122 (patch)
tree15142dde5d6946aad27a47d0d5aac21a65ffe816
parentcc0c05cade929aed6bf2002c78734e5b637047ec (diff)
downloadaur-5a9b5ae3e2301a7f72299969192061e95d904122.tar.gz
fixed permissions problem when makepkg tries to remove $srcdir
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD5
2 files changed, 1 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 865c1056c771..eff24159bd88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,4 +14,3 @@ pkgbase = pistol-git
pkgname = pistol-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c6e61ff9f939..f3f2b702b716 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,15 +19,12 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- chmod -R a+wX "$srcdir/$pkgname"
-}
-
build() {
cd "$srcdir/$pkgname"
# -fix flag is a no-op when using modules
GOPATH="$srcdir" go get -v "$_gourl/cmd/pistol"
strip -x "$srcdir/bin/pistol"
+ chmod -R a+wX "$srcdir/$pkgname"
}
package() {