summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsharethewisdom2019-11-25 16:04:51 +0100
committersharethewisdom2019-11-25 16:04:51 +0100
commit6041832acb937c25e86fdcea887383a8dc573767 (patch)
treed16b8dd66e62101c5872ca10230d4e67d8008dc7
parent5a9b5ae3e2301a7f72299969192061e95d904122 (diff)
downloadaur-6041832acb937c25e86fdcea887383a8dc573767.tar.gz
fixed permissions problem when makepkg tries to remove $srcdir
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eff24159bd88..865c1056c771 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,3 +14,4 @@ pkgbase = pistol-git
pkgname = pistol-git
+
diff --git a/PKGBUILD b/PKGBUILD
index f3f2b702b716..cbd628a91959 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,12 +24,12 @@ build() {
# -fix flag is a no-op when using modules
GOPATH="$srcdir" go get -v "$_gourl/cmd/pistol"
strip -x "$srcdir/bin/pistol"
- chmod -R a+wX "$srcdir/$pkgname"
}
package() {
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" "$srcdir/$pkgname/LICENSE"
install -Dm755 "$srcdir/bin/pistol" "$pkgdir/usr/bin/pistol"
+ chmod -fR a+wX "$srcdir/$pkgname/*"
}
warn_build_references() {