summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsharethewisdom2019-11-25 16:20:45 +0100
committersharethewisdom2019-11-25 16:20:45 +0100
commit87db945df551e627c6fe2b859d68e1d5a7ffe5d7 (patch)
tree868a8344f56417ac3b5b9a2cdaadc33ca50c2195
parentf2b508e380222f17a7183ff62f5ba3e71233829f (diff)
downloadaur-87db945df551e627c6fe2b859d68e1d5a7ffe5d7.tar.gz
fixed permissions problem when makepkg tries to remove $srcdir
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 1 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 865c1056c771..eff24159bd88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,4 +14,3 @@ pkgbase = pistol-git
pkgname = pistol-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ed4f1a353d6a..0f5c11c74d84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,12 +24,12 @@ build() {
# -fix flag is a no-op when using modules
GOPATH="$srcdir" go get -v "$_gourl/cmd/pistol"
strip -x "$srcdir/bin/pistol"
+ chmod -R u+wX "$srcdir/$pkgname/*"
}
package() {
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" "$srcdir/$pkgname/LICENSE"
install -Dm755 "$srcdir/bin/pistol" "$pkgdir/usr/bin/pistol"
- chmod -R u+wX "$srcdir/$pkgname/*"
}
warn_build_references() {