summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsharethewisdom2019-11-25 16:29:25 +0100
committersharethewisdom2019-11-25 16:29:25 +0100
commit88c5cb9a034432605c12614aa1ee42e2fee6a75f (patch)
tree8cbd0ade52c3270d3b4cd8240d180f2576f38502
parent87db945df551e627c6fe2b859d68e1d5a7ffe5d7 (diff)
downloadaur-88c5cb9a034432605c12614aa1ee42e2fee6a75f.tar.gz
fixed permissions problem when makepkg tries to remove $srcdir
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD2
2 files changed, 2 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eff24159bd88..865c1056c771 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,3 +14,4 @@ pkgbase = pistol-git
pkgname = pistol-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 0f5c11c74d84..6f2e0f13e96a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ build() {
# -fix flag is a no-op when using modules
GOPATH="$srcdir" go get -v "$_gourl/cmd/pistol"
strip -x "$srcdir/bin/pistol"
- chmod -R u+wX "$srcdir/$pkgname/*"
+ chmod -R u+wX "$srcdir"
}
package() {