summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeneePatel2021-04-14 16:33:23 +0530
committerKeneePatel2021-04-14 16:33:23 +0530
commit520b20dde8c5f194e3bf05c6ed565fd92831cb5b (patch)
tree34ee39be6406ce1970264d79ee461b41e0bbf01f
downloadaur-520b20dde8c5f194e3bf05c6ed565fd92831cb5b.tar.gz
merged git and bin version to this one
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66c0a036cfc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = piston-cli
+ pkgdesc = A universal shell supporting 36+ languages, in terminal code editor with syntax highlight, code compiler (36+ languages). It can run code from pastebin links and files too.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/Shivansh-007/piston-cli
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-pygments
+ depends = python-requests
+ depends = python-prompt_toolkit
+ depends = python-rich
+ depends = python-argparse
+ provides = piston-cli
+ conflicts = piston-cli
+ source = piston-cli::https://github.com/Shivansh-007/piston-cli/archive/refs/tags/v1.3.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = piston-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..992739307c93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Shivansh <shivansh-007 + aur at outlook <.> com>
+# Maintainer: SuperMazingCoder <supermazingcoder + aur at gmail <.> com>
+# Contributor: Kenee Patel <patelkenee2804 + aur at gmail <.> com>
+
+pkgname=piston-cli
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A universal shell supporting 36+ languages, in terminal code editor with syntax highlight, code compiler (36+ languages). It can run code from pastebin links and files too. "
+arch=('any')
+url="https://github.com/Shivansh-007/piston-cli"
+license=('MIT')
+depends=(
+ 'python-pygments'
+ 'python-requests'
+ 'python-prompt_toolkit'
+ 'python-rich'
+ 'python-argparse'
+)
+makedepends=(
+ 'git'
+ 'python-setuptools'
+)
+optdepends=()
+provides=('piston-cli')
+conflicts=('piston-cli')
+source=(${pkgname}::${url}"/archive/refs/tags/v"${pkgver}".tar.gz")
+sha256sums=('SKIP')
+
+build() {
+ cd $(ls | grep piston-cli-)
+ python setup.py build
+}
+
+package() {
+ cd $(ls | grep piston-cli-)
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+pkgver() {
+ printf "%s" $(curl -s https://api.github.com/repos/Shivansh-007/piston-cli/releases/latest | grep -w "\"name\"" | grep -Eo "[[:digit:]]{1,}.[[:digit:]]{1,}.[[:digit:]]{1,}")
+}
+