summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeister15932020-10-14 20:27:42 +0400
committermeister15932020-10-14 20:43:06 +0400
commit11bdf702b017145b889c66db8b23e207035796c1 (patch)
tree7f25f9f748e070117dbb8ae744e7bf349ea09f23
downloadaur-11bdf702b017145b889c66db8b23e207035796c1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--PitchBox.desktop9
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c168d6cd65ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pitchbox
+ pkgdesc = Small software application for transforming your voice or music in real-time.
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://www.pitchtech.ch/PitchBox
+ arch = x86_64
+ license = none/unknown
+ depends = java-runtime-common
+ depends = java-environment-common
+ depends = ca-certificates-java
+ source = https://www.pitchtech.ch/PitchBox/PitchBox.zip
+ source = PitchBox.desktop
+ sha256sums = 0e6b5e2f597c96e59f8ed8606d60cf1cdbd1b32052eef74e65731256620ada6f
+ sha256sums = 7e3edf07afb93262055e4f4ee52f762a56314a047b83732f0091d760452aea78
+
+pkgname = pitchbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07670a935bad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: meister1593 <leruop@gmail.com>
+pkgname=pitchbox
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Small software application for transforming your voice or music in real-time."
+arch=('x86_64')
+url="https://www.pitchtech.ch/PitchBox"
+license=('none/unknown')
+depends=('java-runtime-common' 'java-environment-common' 'ca-certificates-java')
+makedepends=()
+source=('https://www.pitchtech.ch/PitchBox/PitchBox.zip'
+ 'PitchBox.desktop')
+sha256sums=('0e6b5e2f597c96e59f8ed8606d60cf1cdbd1b32052eef74e65731256620ada6f'
+ '7e3edf07afb93262055e4f4ee52f762a56314a047b83732f0091d760452aea78')
+
+package() {
+ # make pitchbox files structure
+ install -d ${pkgdir}/opt/PitchBox
+ install -d ${pkgdir}/usr/share/applications
+
+ # copy pitchbox to pkgdir
+ cp -a ${srcdir}/PitchBox/* ${pkgdir}/opt/PitchBox
+ chmod 755 ${pkgdir}/opt/PitchBox/PitchBox.jar
+
+ # install desktop file for users
+ install -Dm644 ${srcdir}/PitchBox.desktop -t ${pkgdir}/usr/share/applications
+}
diff --git a/PitchBox.desktop b/PitchBox.desktop
new file mode 100644
index 000000000000..d49db3baee39
--- /dev/null
+++ b/PitchBox.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+
+Type=Application
+Version=2.0.2
+Name=PitchBox
+Comment=Small software application for transforming your voice or music in real-time.
+Exec=java -jar /opt/PitchBox/PitchBox.jar
+Terminal=false
+Categories=Audio;Java;Utility;