summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Allen2015-06-09 11:37:10 -0400
committerSteven Allen2015-06-09 11:43:19 -0400
commit4bbf6b0a16994576856062d0dbd6a9851305de0f (patch)
tree5526d033d86f863447790ffb0a9658400924e8e6
downloadaur-4bbf6b0a16994576856062d0dbd6a9851305de0f.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD30
-rw-r--r--pithos.install12
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..219c8abcff4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = pithos
+ pkgdesc = Pandora Internet Radio player for GNOME
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://pithos.github.io/
+ install = pithos.install
+ arch = any
+ license = GPL3
+ depends = python
+ depends = gtk3
+ depends = python-gobject
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ depends = gst-plugins-base
+ depends = python-setuptools
+ depends = python-cairo
+ optdepends = libkeybinder3: for media keys plugin
+ optdepends = gst-plugins-ugly: MP3 playback support
+ optdepends = libappindicator-gtk3: Unity indicator applet support
+ optdepends = python-pacparser: PAC proxy support
+ optdepends = python-pylast: Last.fm scrobbling support
+ optdepends = libnotify: Notification support
+ optdepends = python-dbus: MPRIS/Screensaver Pause/Gnome mediakeys support
+ source = https://github.com/pithos/pithos/archive/1.1.1.tar.gz
+ sha256sums = 4424534bbf7ab3d3d6c51764d689606fd0df214422eb79ccc91a8981f95d7dce
+
+pkgname = pithos
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9687d71626df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Matthew Bauer <mjbauer95@gmail.com>
+# Contributor: TingPing <tingping@fedoraproject.org>
+# Contributor: Christopher Eby <kreed@kreed.org>
+# Maintainer: Steven Allen <steven@stebalien.com>
+
+pkgname=pithos
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Pandora Internet Radio player for GNOME'
+arch=('any')
+url="http://pithos.github.io/"
+license=('GPL3')
+depends=('python' 'gtk3' 'python-gobject'
+ 'gst-plugins-good' 'gst-plugins-bad' 'gst-plugins-base'
+ 'python-setuptools' 'python-cairo')
+optdepends=('libkeybinder3: for media keys plugin'
+ 'gst-plugins-ugly: MP3 playback support'
+ 'libappindicator-gtk3: Unity indicator applet support'
+ 'python-pacparser: PAC proxy support'
+ 'python-pylast: Last.fm scrobbling support'
+ 'libnotify: Notification support'
+ 'python-dbus: MPRIS/Screensaver Pause/Gnome mediakeys support')
+source=("https://github.com/pithos/pithos/archive/${pkgver}.tar.gz")
+install="$pkgname.install"
+sha256sums=('4424534bbf7ab3d3d6c51764d689606fd0df214422eb79ccc91a8981f95d7dce')
+
+package() {
+ cd "$srcdir/${pkgname}-$pkgver"
+ python setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}/"
+}
diff --git a/pithos.install b/pithos.install
new file mode 100644
index 000000000000..db6d40bae922
--- /dev/null
+++ b/pithos.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}