summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Allen2017-11-29 16:19:09 -0800
committerSteven Allen2017-11-29 16:19:09 -0800
commita85c2083e80bd2e3853e38c784cfe2641e1d3dbc (patch)
tree5c55fa514806d32111ab5b391b397278e562b8a6
parent3079ff1f789c230e53108f8a34d99c4f5ddb7632 (diff)
downloadaur-a85c2083e80bd2e3853e38c784cfe2641e1d3dbc.tar.gz
update to 1.4.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 502c9fec766d..c74f18d460ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pithos
pkgdesc = Native Pandora Radio client
- pkgver = 1.4.0
+ pkgver = 1.4.1
pkgrel = 1
url = https://pithos.github.io/
arch = any
@@ -19,14 +19,12 @@ pkgbase = pithos
optdepends = python-pacparser: PAC proxy support
optdepends = python-pylast: Last.fm scrobbling support
optdepends = python-systemd: Logging to the system journal
- source = https://github.com/pithos/pithos/releases/download/1.4.0/pithos-1.4.0.tar.xz
- source = https://github.com/pithos/pithos/releases/download/1.4.0/pithos-1.4.0.tar.xz.asc
- source = dbus.service
+ source = https://github.com/pithos/pithos/releases/download/1.4.1/pithos-1.4.1.tar.xz
+ source = https://github.com/pithos/pithos/releases/download/1.4.1/pithos-1.4.1.tar.xz.asc
source = systemd.service
validpgpkeys = 108BF2212A051F4A72B18448B3C7CE210DE76DFC
- sha256sums = 4c025d7e1e055292849b80c37d8ad3862e0f2cbd9c7327664deb8ac0389952ac
+ sha256sums = ebc30213ae85716d5a57e30b912f083b2fdb374a793d5adfec00a064fdfc165c
sha256sums = SKIP
- sha256sums = 2b80c9bb84f7de8de0e36dc16465c6633cb74de7bf777efcad76393e88a6e62a
sha256sums = 6d29178697384fb046d9d25c6c2482f353a4484ec4f0a5b9080d1a26aa24f839
pkgname = pithos
diff --git a/PKGBUILD b/PKGBUILD
index 20bfdf573b38..35e96eb7bb7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Steven Allen <steven@stebalien.com>
pkgname=pithos
-pkgver=1.4.0
+pkgver=1.4.1
pkgrel=1
pkgdesc='Native Pandora Radio client'
arch=('any')
@@ -20,16 +20,19 @@ optdepends=('libkeybinder3: for media keys plugin'
makedepends=('meson' 'appstream-glib')
source=(
"https://github.com/pithos/pithos/releases/download/${pkgver}/pithos-${pkgver}.tar.xz"{,.asc}
- "dbus.service"
"systemd.service"
)
-sha256sums=('4c025d7e1e055292849b80c37d8ad3862e0f2cbd9c7327664deb8ac0389952ac'
+sha256sums=('ebc30213ae85716d5a57e30b912f083b2fdb374a793d5adfec00a064fdfc165c'
'SKIP'
- '2b80c9bb84f7de8de0e36dc16465c6633cb74de7bf777efcad76393e88a6e62a'
'6d29178697384fb046d9d25c6c2482f353a4484ec4f0a5b9080d1a26aa24f839')
validpgpkeys=('108BF2212A051F4A72B18448B3C7CE210DE76DFC')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ echo "SystemdService=pithos.service" >> "data/io.github.Pithos.service.in"
+}
+
build() {
cd "${srcdir}"
if [[ -d ./build/ ]]; then
@@ -42,6 +45,5 @@ build() {
package() {
cd "${srcdir}/build"
DESTDIR="${pkgdir}" ninja install
- install -Dm644 "${srcdir}/dbus.service" "${pkgdir}/usr/share/dbus-1/services/io.github.Pithos.service"
install -Dm644 "${srcdir}/systemd.service" "${pkgdir}/usr/lib/systemd/user/pithos.service"
}