summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-05-01 19:18:54 +0000
committerDaniel Bermond2020-05-01 19:18:54 +0000
commitae5eeb4e5202a4b39d3ed725558b3777e03ca025 (patch)
treeecda064293663aa065984869f045a1b26ac7f78f
parent40e6efb91b5ccbc73fb0772d20f3de73fdd55bd3 (diff)
downloadaur-ae5eeb4e5202a4b39d3ed725558b3777e03ca025.tar.gz
Match latest upstream changes
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD43
-rw-r--r--pitivi-git-fix-locale-on-tests.patch12
3 files changed, 14 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c581fb66f453..6d77843e126f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = pitivi-git
pkgdesc = Editor for audio/video projects using the GStreamer framework (git version)
- pkgver = 0.999.0.r589.gc1a94d28
+ pkgver = 0.999.0.r881.g7739e04c
pkgrel = 1
url = http://www.pitivi.org/
arch = x86_64
license = LGPL
checkdepends = gst-validate
+ checkdepends = gst-plugin-gtk
checkdepends = zbar
checkdepends = lilv
checkdepends = libkate
@@ -40,9 +41,7 @@ pkgbase = pitivi-git
provides = pitivi
conflicts = pitivi
source = git+https://gitlab.gnome.org/GNOME/pitivi.git
- source = pitivi-git-fix-locale-on-tests.patch
sha256sums = SKIP
- sha256sums = db34a01202ae93b217f7eb5ab6d5e6d928c1c2ecdb652a2d157452078f867858
pkgname = pitivi-git
diff --git a/PKGBUILD b/PKGBUILD
index 30b4e67c4801..f964796f59f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
# Contributor: Kerrick Staley <mail@kerrickstaley.com>
# Contributor: Thomas Schneider <maxmusterm@gmail.com>
@@ -6,7 +6,7 @@
# Contributor: Gabor Nyekhelyi (n0gabor) <n0gabor@vipmail.hu>
pkgname=pitivi-git
-pkgver=0.999.0.r589.gc1a94d28
+pkgver=0.999.0.r881.g7739e04c
pkgrel=1
pkgdesc='Editor for audio/video projects using the GStreamer framework (git version)'
arch=('x86_64')
@@ -19,53 +19,34 @@ optdepends=('frei0r-plugins: for additional video effects, clip transformation f
'gst-libav: for additional multimedia codecs'
'gst-plugins-ugly: for additional multimedia codecs')
makedepends=('git' 'gettext' 'itstool' 'meson' 'appstream-glib')
-checkdepends=('gst-validate' 'zbar' 'lilv' 'libkate' 'fluidsynth' 'qt5-base'
- 'qt5-declarative' 'qt5-x11extras' 'gst-libav' 'xorg-server-xvfb')
+checkdepends=('gst-validate' 'gst-plugin-gtk' 'zbar' 'lilv' 'libkate' 'fluidsynth'
+ 'qt5-base' 'qt5-declarative' 'qt5-x11extras' 'gst-libav' 'xorg-server-xvfb')
provides=('pitivi')
conflicts=('pitivi')
BUILDENV+=('!check')
-source=('git+https://gitlab.gnome.org/GNOME/pitivi.git'
- 'pitivi-git-fix-locale-on-tests.patch')
-sha256sums=('SKIP'
- 'db34a01202ae93b217f7eb5ab6d5e6d928c1c2ecdb652a2d157452078f867858')
-
-prepare() {
- cd pitivi
-
- # fix locale on tests
- patch -Np1 -i "${srcdir}/pitivi-git-fix-locale-on-tests.patch"
-}
+source=('git+https://gitlab.gnome.org/GNOME/pitivi.git')
+sha256sums=('SKIP')
pkgver() {
- cd pitivi
-
local _version
local _revision
local _shorthash
-
- _version="$(git tag | grep '[[0-9]*\.]*[0-9]*' | sort -r | head -n1)"
- _revision="$(git rev-list "${_version}..HEAD" --count)"
- _shorthash="$(git rev-parse --short HEAD)"
-
+ _version="$(git -C pitivi tag | grep '[[0-9]*\.]*[0-9]*' | sort -r | head -n1)"
+ _revision="$(git -C pitivi rev-list "${_version}..HEAD" --count)"
+ _shorthash="$(git -C pitivi rev-parse --short HEAD)"
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- cd pitivi
-
- arch-meson . build
-
- ninja -C build
+ arch-meson pitivi/build pitivi
+ ninja -C pitivi/build
}
check() {
cd pitivi
-
xvfb-run gst-validate-launcher tests/ptv_testsuite.py
}
package() {
- cd pitivi
-
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" ninja -C pitivi/build install
}
diff --git a/pitivi-git-fix-locale-on-tests.patch b/pitivi-git-fix-locale-on-tests.patch
deleted file mode 100644
index ff3da45a20e8..000000000000
--- a/pitivi-git-fix-locale-on-tests.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nawurp a/tests/common.py b/tests/common.py
---- a/tests/common.py 2019-07-06 17:41:49.000000000 +0000
-+++ b/tests/common.py 2019-07-06 17:41:49.000000000 +0000
-@@ -75,7 +75,7 @@ for category in ["Gtk", "Gdk", "GLib-GOb
-
- detect_leaks = os.environ.get("PITIVI_TEST_DETECT_LEAKS", "0") not in ("0", "")
- os.environ["PITIVI_USER_CACHE_DIR"] = tempfile.mkdtemp(suffix="pitiviTestsuite")
--locale.setlocale(locale.LC_ALL, "en_US")
-+locale.setlocale(locale.LC_ALL, "en_US.UTF-8")
-
-
- def __create_settings(proxyingStrategy=ProxyingStrategy.NOTHING,