summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Miller2018-07-15 19:31:17 -0700
committerAaron Miller2018-07-15 19:31:17 -0700
commit344a167bb1ee0a697cb93bd58348a4672a8b8bd1 (patch)
treeaf853c989bad50d85938f0ec284e12056de31ed4
parent3fe02e0139632a863beb8f89e27983247e15e586 (diff)
downloadaur-344a167bb1ee0a697cb93bd58348a4672a8b8bd1.tar.gz
v3.1.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7382ba1a8e39..6066ac5a1577 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = pivx
pkgdesc = Transactional security and privacy-focused decentralized open source cryptocurrency
- pkgver = 3.1.0.2
+ pkgver = 3.1.1
pkgrel = 1
url = https://pivx.org/
arch = i686
arch = x86_64
license = MIT
depends = boost-libs
- source = https://github.com/PIVX-Project/PIVX/archive/v3.1.0.2.tar.gz
- sha256sums = 50db22d2a8188cee03c81c57e361ba80bf80d60747dbe89c1fd186a3198f64d0
- source_i686 = https://github.com/PIVX-Project/PIVX/releases/download/v3.1.0.2/pivx-3.1.0.2-i686-pc-linux-gnu.tar.gz
- sha256sums_i686 = 70e62cf936cfa189eb479110e5d727e162d41fc15490e93868f8b7e742883f8a
- source_x86_64 = https://github.com/PIVX-Project/PIVX/releases/download/v3.1.0.2/pivx-3.1.0.2-x86_64-linux-gnu.tar.gz
- sha256sums_x86_64 = 0ea18dcbefacd211739e1a64fe80e70cd6b9bf3f5d82b111e6c2aa2f271a35c5
+ source = https://github.com/PIVX-Project/PIVX/archive/v3.1.1.tar.gz
+ sha256sums = b85f50a0e149ac2402b8d0fe155c7252163c825e0a6410d198b9c3ebc796fdf2
+ source_i686 = https://github.com/PIVX-Project/PIVX/releases/download/v3.1.1/pivx-3.1.1-i686-pc-linux-gnu.tar.gz
+ sha256sums_i686 = 4e267b98f4f0723363985549612053e2cb341ddd676f69a5300a333fc52dcb9d
+ source_x86_64 = https://github.com/PIVX-Project/PIVX/releases/download/v3.1.1/pivx-3.1.1-x86_64-linux-gnu.tar.gz
+ sha256sums_x86_64 = aac5b13beb9ff96b0ce62d2258d54166c756c8336672a67c7aae6b73a76b0c03
pkgname = pivx-daemon
pkgdesc = Transactional security and privacy-focused decentralized open source cryptocurrency (daemon)
diff --git a/PKGBUILD b/PKGBUILD
index b5296a280314..dff83c91fce8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,7 @@
pkgname=("pivx-daemon" "pivx-cli" "pivx-qt")
pkgbase=pivx
_pkgbase=${pkgbase^^}
-pkgver=3.1.0.2
-_pkgdirver=3.1.0
+pkgver=3.1.1
pkgrel=1
arch=("i686" "x86_64")
url="https://pivx.org/"
@@ -14,15 +13,15 @@ license=("MIT")
source=("https://github.com/PIVX-Project/PIVX/archive/v$pkgver.tar.gz")
source_i686=("https://github.com/PIVX-Project/PIVX/releases/download/v$pkgver/pivx-$pkgver-i686-pc-linux-gnu.tar.gz")
source_x86_64=("https://github.com/PIVX-Project/PIVX/releases/download/v$pkgver/pivx-$pkgver-x86_64-linux-gnu.tar.gz")
-sha256sums=("50db22d2a8188cee03c81c57e361ba80bf80d60747dbe89c1fd186a3198f64d0")
-sha256sums_i686=("70e62cf936cfa189eb479110e5d727e162d41fc15490e93868f8b7e742883f8a")
-sha256sums_x86_64=("0ea18dcbefacd211739e1a64fe80e70cd6b9bf3f5d82b111e6c2aa2f271a35c5")
+sha256sums=("b85f50a0e149ac2402b8d0fe155c7252163c825e0a6410d198b9c3ebc796fdf2")
+sha256sums_i686=("4e267b98f4f0723363985549612053e2cb341ddd676f69a5300a333fc52dcb9d")
+sha256sums_x86_64=("aac5b13beb9ff96b0ce62d2258d54166c756c8336672a67c7aae6b73a76b0c03")
package_pivx-daemon() {
pkgdesc+="(daemon)"
depends+=("openssl" "miniupnpc" "db4.8")
- cd "${srcdir}/${pkgbase}-${_pkgdirver}"
+ cd "${srcdir}/${pkgbase}-${pkgver}"
install -Dm755 "bin/pivxd" "${pkgdir}/usr/bin/pivxd"
cd "${srcdir}/${_pkgbase}-${pkgver}"
@@ -37,7 +36,7 @@ package_pivx-cli() {
pkgdesc+="(CLI)"
depends+=("openssl")
- cd "${srcdir}/${pkgbase}-${_pkgdirver}"
+ cd "${srcdir}/${pkgbase}-${pkgver}"
install -Dm755 "bin/pivx-cli" "${pkgdir}/usr/bin/pivx-cli"
install -Dm755 "bin/pivx-tx" "${pkgdir}/usr/bin/pivx-tx"
@@ -49,7 +48,7 @@ package_pivx-qt() {
pkgdesc+="(Qt)"
depends+=("qt5-base" "protobuf" "qrencode" "miniupnpc" "db4.8")
- cd "${srcdir}/${pkgbase}-${_pkgdirver}"
+ cd "${srcdir}/${pkgbase}-${pkgver}"
install -Dm755 "bin/pivx-qt" "${pkgdir}/usr/bin/pivx-qt"
cd "${srcdir}/${_pkgbase}-${pkgver}"