summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wilson2019-04-12 13:39:37 -0700
committerAlex Wilson2019-04-12 13:40:17 -0700
commit039397c466ca4ab77bd196d132bab580db5ad10a (patch)
treef9353047716b9716be9f0439e4ea2518f898f007
downloadaur-039397c466ca4ab77bd196d132bab580db5ad10a.tar.gz
Release 0.1.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85a312667fa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pivy
+ pkgver = 0.1.0
+ pkgrel = 1
+ arch = x86
+ arch = x86_64
+ depends = libbsd
+ depends = pcsclite
+ depends = libedit
+ source = https://github.com/arekinath/pivy/archive/v0.1.0.tar.gz
+ source = https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz
+ md5sums = 3eed4156a6161f9448e95c07cb8111d4
+ md5sums = 94ce8f4cdbb6b57565da61e380d63045
+
+pkgname = pivy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0c56dda0036
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Alex Wilson <alex at cooperi dot net>
+pkgname=pivy
+pkgver=0.1.0
+pkgrel=1
+source=(
+ "https://github.com/arekinath/pivy/archive/v0.1.0.tar.gz"
+ "https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz")
+arch=(x86 x86_64)
+depends=(libbsd pcsclite libedit)
+makedepends=()
+md5sums=('3eed4156a6161f9448e95c07cb8111d4'
+ '94ce8f4cdbb6b57565da61e380d63045')
+
+prepare() {
+ mv "libressl-2.7.4" "$pkgname-$pkgver/libressl"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cd libressl
+ ./configure --enable-static
+ cd crypto
+ make
+ cd ../..
+ make prefix=/usr
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make prefix=/usr DESTDIR="$pkgdir/" install
+}