summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wilson2021-03-10 16:18:09 +1000
committerAlex Wilson2021-03-10 16:18:09 +1000
commit17ff3550af3c47fcad6ffc4689f93ea249d4226b (patch)
tree08eeab396dfb221edd087c29b7a6a6bc7cd7ac30
parentdccbdab6b9d9964eff6e39db2185f64be0f0b353 (diff)
downloadaur-17ff3550af3c47fcad6ffc4689f93ea249d4226b.tar.gz
Release 0.8.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--zfs-pivy.hook4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edca921ea879..b65f9519ab17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pivy
pkgdesc = Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption
- pkgver = 0.7.1
+ pkgver = 0.8.0
pkgrel = 1
url = https://github.com/arekinath/pivy
arch = x86
@@ -19,12 +19,12 @@ pkgbase = pivy
optdepends = pam: PAM plugin (pam_pivy.so)
source = zfs-pivy.hook
source = zfs-pivy.install
- source = https://github.com/arekinath/pivy/archive/v0.7.1.tar.gz
+ source = https://github.com/arekinath/pivy/archive/v0.8.0.tar.gz
source = https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.1.0.tar.gz
source = https://github.com/arekinath/mini-pcsc/archive/v0.2.0.tar.gz
sha256sums = c78b9420751cd70c4b6cf2d437110c71452cbd6c8c44c5338c29ed7d80cba26c
sha256sums = 44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678
- sha256sums = d7289ec83549e59b006b8f7303d4fec8cf80fb074ab30173426cadd13b94081e
+ sha256sums = c32b008a730ddc8661e4b0542408b30d46868ee66890612b7f1cbc84803eaf57
sha256sums = f91aad0c8fb9cbc67c910ad6dcffb401a819b4fd122007ea7f978638db044cf6
sha256sums = a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e
diff --git a/PKGBUILD b/PKGBUILD
index b8d41ce7b535..a7c58f6451b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alex Wilson <alex at cooperi dot net>
pkgname=pivy
-pkgver=0.7.1
+pkgver=0.8.0
pkgrel=1
pkgdesc="Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption"
url="https://github.com/arekinath/pivy"
@@ -19,7 +19,7 @@ optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
makedepends=(pkgconf cryptsetup zfs-utils json-c pam)
sha256sums=('c78b9420751cd70c4b6cf2d437110c71452cbd6c8c44c5338c29ed7d80cba26c'
'44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678'
- 'd7289ec83549e59b006b8f7303d4fec8cf80fb074ab30173426cadd13b94081e'
+ 'c32b008a730ddc8661e4b0542408b30d46868ee66890612b7f1cbc84803eaf57'
'f91aad0c8fb9cbc67c910ad6dcffb401a819b4fd122007ea7f978638db044cf6'
'a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e')
diff --git a/zfs-pivy.hook b/zfs-pivy.hook
index 6a01766ff03a..b5b8b75f2cb0 100644
--- a/zfs-pivy.hook
+++ b/zfs-pivy.hook
@@ -105,7 +105,7 @@ zfs_mount_handler () {
mountpoint=$(zfs get -H -o value mountpoint "${dataset}")
canmount=$(zfs get -H -o value canmount "${dataset}")
# skip dataset
- [ ${canmount} = "off" -o ${mountpoint} = "none" ] && continue
+ [ ${dataset} != "${ZFS_DATASET}" -a \( ${canmount} = "off" -o ${canmount} = "noauto" -o ${mountpoint} = "none" \) ] && continue
if [ ${mountpoint} = "legacy" ]; then
if [ -f "${tab_file}" ]; then
if findmnt -snero source -F "${tab_file}" -S "${dataset}" > /dev/null 2>&1; then
@@ -152,7 +152,7 @@ run_hook() {
pcscd_pid=
}
msg ":: waiting for smartcard devices..."
- sleep 5
+ sleep 5
udevadm trigger &
sleep 1
pcscd --hotplug