summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wilson2019-06-15 18:30:58 -0700
committerAlex Wilson2019-06-15 18:32:20 -0700
commit1f64e272da5969e7b06952f3d3cff47d1d8a2515 (patch)
treeac6192df2f8b6e3ac81f8ba8830bbd7c99a54a2d
parent6be9da54595000551a6b794deeba02ef60bb3c28 (diff)
downloadaur-1f64e272da5969e7b06952f3d3cff47d1d8a2515.tar.gz
Release 0.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46989534a9cd..f3497510f070 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = pivy
pkgdesc = Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption
- pkgver = 0.1.6
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/arekinath/pivy
arch = x86
arch = x86_64
license = MPL2
+ makedepends = cryptsetup
+ makedepends = zfs-utils
+ makedepends = json-c
depends = libbsd
depends = pcsclite
depends = libedit
- source = https://github.com/arekinath/pivy/archive/v0.1.6.tar.gz
+ optdepends = cryptsetup: LUKS encrypted disk support (pivy-luks)
+ optdepends = zfs-utils: ZFS encrypted pool/fs support (pivy-zfs)
+ source = https://github.com/arekinath/pivy/archive/v0.2.0.tar.gz
source = https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz
- sha256sums = 8f426fab331534ea96f3b4eef3df5ce963c2a4de6906160943066b33698d2046
+ sha256sums = 51e3651a0fae8fe150157130c7380efb29c57b00ba6371c765484e0ae82a9906
sha256sums = 1e3a9fada06c1c060011470ad0ff960de28f9a0515277d7336f7e09362517da6
pkgname = pivy
diff --git a/PKGBUILD b/PKGBUILD
index ba404d974d2f..0b1f7d712e22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alex Wilson <alex at cooperi dot net>
pkgname=pivy
-pkgver=0.1.6
+pkgver=0.2.0
pkgrel=1
pkgdesc="Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption"
url="https://github.com/arekinath/pivy"
@@ -10,8 +10,10 @@ source=(
"https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz")
arch=(x86 x86_64)
depends=(libbsd pcsclite libedit)
-makedepends=()
-sha256sums=('8f426fab331534ea96f3b4eef3df5ce963c2a4de6906160943066b33698d2046'
+optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
+ 'zfs-utils: ZFS encrypted pool/fs support (pivy-zfs)')
+makedepends=(cryptsetup zfs-utils json-c)
+sha256sums=('51e3651a0fae8fe150157130c7380efb29c57b00ba6371c765484e0ae82a9906'
'1e3a9fada06c1c060011470ad0ff960de28f9a0515277d7336f7e09362517da6')
prepare() {
@@ -20,10 +22,10 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
- make prefix=/usr
+ make prefix=/usr USE_ZFS=yes USE_LUKS=yes
}
package() {
cd "$pkgname-$pkgver"
- make prefix=/usr DESTDIR="$pkgdir/" install
+ make prefix=/usr DESTDIR="$pkgdir/" USE_ZFS=yes USE_LUKS=yes install
}