summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wilson2019-10-24 18:24:39 +1000
committerAlex Wilson2019-10-24 18:24:39 +1000
commit257461020dc2867cf4702d25b3cba3a63eda857b (patch)
treeb8a09df8e2f293a8df048a9bfd55ac22cc97834d
parentdd068d3a8334d769fa6466dce0210002fde02854 (diff)
downloadaur-257461020dc2867cf4702d25b3cba3a63eda857b.tar.gz
Release 0.3.1, mini-pcsc 0.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f74f0a6252f5..986ac898d1b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pivy
pkgdesc = Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption
- pkgver = 0.3.0
- pkgrel = 2
+ pkgver = 0.3.1
+ pkgrel = 1
url = https://github.com/arekinath/pivy
arch = x86
arch = x86_64
@@ -17,14 +17,14 @@ pkgbase = pivy
optdepends = zfs-utils: ZFS encrypted pool/fs support (pivy-zfs)
source = zfs-pivy.hook
source = zfs-pivy.install
- source = https://github.com/arekinath/pivy/archive/v0.3.0.tar.gz
+ source = https://github.com/arekinath/pivy/archive/v0.3.1.tar.gz
source = https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz
- source = https://github.com/arekinath/mini-pcsc/archive/v0.1.0.tar.gz
+ source = https://github.com/arekinath/mini-pcsc/archive/v0.2.0.tar.gz
sha256sums = 404e1ba4ab21e030f1661898d21c6a64a7dda5ad12cee678e33ad77856557f1b
sha256sums = 44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678
- sha256sums = f29ae879030bcd72a04df71b1854d1cf9ecda130825efc80ab7fe3b74d3735b8
+ sha256sums = e0fdfd6c39fab493c57dccc236a8e775b7b8933f0876c28f495af5fe240b6acd
sha256sums = 1e3a9fada06c1c060011470ad0ff960de28f9a0515277d7336f7e09362517da6
- sha256sums = aff68661c77bde91d67bfe3a132fab1bfa6e445281c7362caa59e5238b228e66
+ sha256sums = a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e
pkgname = pivy
diff --git a/PKGBUILD b/PKGBUILD
index 3e3d988d1715..e1347786acfa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Wilson <alex at cooperi dot net>
pkgname=pivy
-pkgver=0.3.0
-pkgrel=2
+pkgver=0.3.1
+pkgrel=1
pkgdesc="Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption"
url="https://github.com/arekinath/pivy"
license=('MPL2')
@@ -10,7 +10,7 @@ source=(
"zfs-pivy.install"
"https://github.com/arekinath/pivy/archive/v$pkgver.tar.gz"
"https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz"
- "https://github.com/arekinath/mini-pcsc/archive/v0.1.0.tar.gz")
+ "https://github.com/arekinath/mini-pcsc/archive/v0.2.0.tar.gz")
arch=(x86 x86_64)
depends=(libbsd pcsclite libedit)
optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
@@ -18,9 +18,9 @@ optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
makedepends=(pkgconf cryptsetup zfs-utils json-c)
sha256sums=('404e1ba4ab21e030f1661898d21c6a64a7dda5ad12cee678e33ad77856557f1b'
'44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678'
- 'f29ae879030bcd72a04df71b1854d1cf9ecda130825efc80ab7fe3b74d3735b8'
+ 'e0fdfd6c39fab493c57dccc236a8e775b7b8933f0876c28f495af5fe240b6acd'
'1e3a9fada06c1c060011470ad0ff960de28f9a0515277d7336f7e09362517da6'
- 'aff68661c77bde91d67bfe3a132fab1bfa6e445281c7362caa59e5238b228e66')
+ 'a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e')
prepare() {
mv "libressl-2.7.4" "$pkgname-$pkgver/libressl"
@@ -29,7 +29,7 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
make prefix=/usr USE_ZFS=yes USE_LUKS=yes
- cd "../mini-pcsc-0.1.0"
+ cd "../mini-pcsc-0.2.0"
make
}
@@ -37,7 +37,7 @@ package() {
cd "$pkgname-$pkgver"
make prefix=/usr DESTDIR="$pkgdir/" USE_ZFS=yes USE_LUKS=yes install
- cd "../mini-pcsc-0.1.0"
+ cd "../mini-pcsc-0.2.0"
install -o root -g root -m 0755 -d "${pkgdir}/usr/lib"
install -o root -g root -m 0755 libminipcsc.so "${pkgdir}/usr/lib/libminipcsc.so"