summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wilson2020-03-05 22:07:02 +1000
committerAlex Wilson2020-03-05 22:07:02 +1000
commit3a2507b44827c54d3f4187fdf76183178848a19d (patch)
tree59b6d66fc7d597be64f6fef1920decd3958d8d5e
parent257461020dc2867cf4702d25b3cba3a63eda857b (diff)
downloadaur-3a2507b44827c54d3f4187fdf76183178848a19d.tar.gz
Typo in initcpio hook prevents unlock of nested datasets
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--zfs-pivy.hook4
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 986ac898d1b3..f121e2ef4230 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pivy
pkgdesc = Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption
pkgver = 0.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/arekinath/pivy
arch = x86
arch = x86_64
@@ -20,7 +20,7 @@ pkgbase = pivy
source = https://github.com/arekinath/pivy/archive/v0.3.1.tar.gz
source = https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.7.4.tar.gz
source = https://github.com/arekinath/mini-pcsc/archive/v0.2.0.tar.gz
- sha256sums = 404e1ba4ab21e030f1661898d21c6a64a7dda5ad12cee678e33ad77856557f1b
+ sha256sums = c78b9420751cd70c4b6cf2d437110c71452cbd6c8c44c5338c29ed7d80cba26c
sha256sums = 44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678
sha256sums = e0fdfd6c39fab493c57dccc236a8e775b7b8933f0876c28f495af5fe240b6acd
sha256sums = 1e3a9fada06c1c060011470ad0ff960de28f9a0515277d7336f7e09362517da6
diff --git a/PKGBUILD b/PKGBUILD
index e1347786acfa..2d33a9c699dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Wilson <alex at cooperi dot net>
pkgname=pivy
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption"
url="https://github.com/arekinath/pivy"
license=('MPL2')
@@ -16,7 +16,7 @@ depends=(libbsd pcsclite libedit)
optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
'zfs-utils: ZFS encrypted pool/fs support (pivy-zfs)')
makedepends=(pkgconf cryptsetup zfs-utils json-c)
-sha256sums=('404e1ba4ab21e030f1661898d21c6a64a7dda5ad12cee678e33ad77856557f1b'
+sha256sums=('c78b9420751cd70c4b6cf2d437110c71452cbd6c8c44c5338c29ed7d80cba26c'
'44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678'
'e0fdfd6c39fab493c57dccc236a8e775b7b8933f0876c28f495af5fe240b6acd'
'1e3a9fada06c1c060011470ad0ff960de28f9a0515277d7336f7e09362517da6'
diff --git a/zfs-pivy.hook b/zfs-pivy.hook
index dd5bd3506211..6a01766ff03a 100644
--- a/zfs-pivy.hook
+++ b/zfs-pivy.hook
@@ -40,11 +40,13 @@ zfs_decrypt_fs() {
# get the encryption root
encryptionroot=$(zfs get -H -o value encryptionroot "${dataset}")
+ msg "ZFS: unlocking ${encryptionroot}"
+
# export encription root to be used by other hooks (SSH)
echo "${encryptionroot}" > /.encryptionroot
# if the dataset has an ebox, use pivy-zfs to unlock it
- if [ "$(zfs get -H -o source rfd77:ebox "${dataset}")" == "local" ]; then
+ if [ "$(zfs get -H -o source rfd77:ebox "${encryptionroot}")" == "local" ]; then
# loop until pivy-zfs unlock succeeds
while [ "$(zfs get -H -o value keystatus "${encryptionroot}")" != "available" ] &&
! eval pivy-zfs unlock "${encryptionroot}"; do