summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wilson2022-04-27 15:28:21 +1000
committerAlex Wilson2022-04-27 15:28:21 +1000
commitf4057576e45609f26603b5bfcf028e582b36187d (patch)
tree30b14c4ef220e371782b047f400c621aa34749b7
parent14eb7308203ad6a648be5bafe2a5f4825136d8ee (diff)
downloadaur-f4057576e45609f26603b5bfcf028e582b36187d.tar.gz
Release 0.9.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1540cdd9b869..448a3f59c4bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pivy
pkgdesc = Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption
- pkgver = 0.8.0
+ pkgver = 0.9.0
pkgrel = 2
url = https://github.com/arekinath/pivy
arch = x86
@@ -19,14 +19,11 @@ pkgbase = pivy
optdepends = pam: PAM plugin (pam_pivy.so)
source = zfs-pivy.hook
source = zfs-pivy.install
- source = https://github.com/arekinath/pivy/archive/v0.8.0.tar.gz
- source = https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.1.0.tar.gz
+ source = https://github.com/arekinath/pivy/releases/download/v0.9.0/pivy-0.9.0-src.tar.gz
source = https://github.com/arekinath/mini-pcsc/archive/v0.2.0.tar.gz
sha256sums = 7925467b71227ae835cc5bf5ebf0b74ea6d740738af5d13be05e0416a78f8acc
sha256sums = 44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678
- sha256sums = c32b008a730ddc8661e4b0542408b30d46868ee66890612b7f1cbc84803eaf57
- sha256sums = f91aad0c8fb9cbc67c910ad6dcffb401a819b4fd122007ea7f978638db044cf6
+ sha256sums = a2e4574142e7112cf2434566a51697ebabe28916d42ab0729c54dfea6f7c420e
sha256sums = a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e
pkgname = pivy
-
diff --git a/PKGBUILD b/PKGBUILD
index f69f55aaa8dd..748ad6d4b95f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alex Wilson <alex at cooperi dot net>
pkgname=pivy
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=2
pkgdesc="Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption"
url="https://github.com/arekinath/pivy"
@@ -8,8 +8,7 @@ license=('MPL2')
source=(
"zfs-pivy.hook"
"zfs-pivy.install"
- "https://github.com/arekinath/pivy/archive/v$pkgver.tar.gz"
- "https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-3.1.0.tar.gz"
+ "https://github.com/arekinath/pivy/releases/download/v$pkgver/pivy-$pkgver-src.tar.gz"
"https://github.com/arekinath/mini-pcsc/archive/v0.2.0.tar.gz")
arch=(x86 x86_64)
depends=(libbsd pcsclite libedit)
@@ -19,17 +18,12 @@ optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
makedepends=(pkgconf cryptsetup zfs-utils json-c pam)
sha256sums=('7925467b71227ae835cc5bf5ebf0b74ea6d740738af5d13be05e0416a78f8acc'
'44b5a004a06ffe214df2810bb2d58a3ecb2bdcf1c892411a8d574afac935f678'
- 'c32b008a730ddc8661e4b0542408b30d46868ee66890612b7f1cbc84803eaf57'
- 'f91aad0c8fb9cbc67c910ad6dcffb401a819b4fd122007ea7f978638db044cf6'
+ 'a2e4574142e7112cf2434566a51697ebabe28916d42ab0729c54dfea6f7c420e'
'a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e')
# Don't use --as-needed when linking, will break pam_pivy
LDFLAGS+=" -Wl,--no-as-needed"
-prepare() {
- mv "libressl-3.1.0" "$pkgname-$pkgver/libressl"
-}
-
build() {
cd "$pkgname-$pkgver"
make prefix=/usr USE_ZFS=yes USE_LUKS=yes USE_PAM=yes