summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Wilson2022-08-30 16:32:10 +1000
committerAlex Wilson2022-08-30 16:32:10 +1000
commitfe14e64e4fb77555a720a78c516fef8cc41dbd28 (patch)
tree1346fe9088013358c968503bdba6bb6f91d7cb53
parent232570c1f232e7fb99a1ef6bff617fd52d58a23e (diff)
downloadaur-fe14e64e4fb77555a720a78c516fef8cc41dbd28.tar.gz
Release 0.10.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c54d13f67d55..f01245042868 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pivy
pkgdesc = Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption
- pkgver = 0.9.0
- pkgrel = 3
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://github.com/arekinath/pivy
arch = x86
arch = x86_64
@@ -19,11 +19,11 @@ pkgbase = pivy
optdepends = pam: PAM plugin (pam_pivy.so)
source = zfs-pivy.hook
source = zfs-pivy.install
- source = https://github.com/arekinath/pivy/releases/download/v0.9.0/pivy-0.9.0-src.tar.gz
+ source = https://github.com/arekinath/pivy/releases/download/v0.10.0/pivy-0.10.0-src.tar.gz
source = https://github.com/arekinath/mini-pcsc/archive/v0.2.0.tar.gz
sha256sums = 7925467b71227ae835cc5bf5ebf0b74ea6d740738af5d13be05e0416a78f8acc
sha256sums = 8da0bc793ba9b7fb1cb784af1ed066aea478b93715f484e7fb7921184d675b84
- sha256sums = a2e4574142e7112cf2434566a51697ebabe28916d42ab0729c54dfea6f7c420e
+ sha256sums = 215012c0b4b51061b174e27888d765259bbe6bf11f636749b2a71554154681f3
sha256sums = a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e
pkgname = pivy
diff --git a/PKGBUILD b/PKGBUILD
index b41c06510bf6..4538ac7238c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Wilson <alex at cooperi dot net>
pkgname=pivy
-pkgver=0.9.0
-pkgrel=3
+pkgver=0.10.0
+pkgrel=1
pkgdesc="Tools for using PIV smartcards/Yubikeys with ssh-agent and disk encryption"
url="https://github.com/arekinath/pivy"
license=('MPL2')
@@ -18,7 +18,7 @@ optdepends=('cryptsetup: LUKS encrypted disk support (pivy-luks)'
makedepends=(pkgconf cryptsetup zfs-utils json-c pam)
sha256sums=('7925467b71227ae835cc5bf5ebf0b74ea6d740738af5d13be05e0416a78f8acc'
'8da0bc793ba9b7fb1cb784af1ed066aea478b93715f484e7fb7921184d675b84'
- 'a2e4574142e7112cf2434566a51697ebabe28916d42ab0729c54dfea6f7c420e'
+ '215012c0b4b51061b174e27888d765259bbe6bf11f636749b2a71554154681f3'
'a2c23b7b9e3dc976b54627a08da68b76fd6194ba45d211959dedf4700879379e')
# Don't use --as-needed when linking, will break pam_pivy
@@ -26,14 +26,14 @@ LDFLAGS+=" -Wl,--no-as-needed"
build() {
cd "$pkgname-$pkgver"
- make prefix=/usr USE_ZFS=yes USE_LUKS=yes USE_PAM=yes
+ make prefix=/usr USE_ZFS=yes USE_LUKS=yes USE_PAM=yes USE_JSONC=yes
cd "../mini-pcsc-0.2.0"
make
}
package() {
cd "$pkgname-$pkgver"
- make prefix=/usr DESTDIR="$pkgdir/" USE_ZFS=yes USE_LUKS=yes USE_PAM=yes install
+ make prefix=/usr DESTDIR="$pkgdir/" USE_ZFS=yes USE_LUKS=yes USE_PAM=yes USE_JSONC=yes install
cd "../mini-pcsc-0.2.0"
install -o root -g root -m 0755 -d "${pkgdir}/usr/lib"