summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2021-09-16 15:16:31 +0200
committerHenry-Joseph Audéoud2021-10-18 11:11:11 +0200
commitfa2a80ea6a11e486eccfedefce6afd7a6c2a25cd (patch)
treea3781add7d25832a7f6180dafffec732e755975b
parent246f3f2a2df03fabca57519f35e183657c0ebae1 (diff)
downloadaur-fa2a80ea6a11e486eccfedefce6afd7a6c2a25cd.tar.gz
Fix optional dependencies and dynamic pkgver computation
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33f60988a320..5034c2fb521a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
pkgbase = piwigo
pkgdesc = Photo gallery software for the web
pkgver = 11.5.0
- pkgrel = 2
+ pkgrel = 3
url = https://piwigo.org/
arch = any
license = GPL
makedepends = unzip
depends = php
- depends = php-gd
depends = mariadb
- optdepends = php-apache: to use the Apache web server
+ depends = php-apache
+ optdepends = php-gd: graphic library (one graphic library is required)
+ optdepends = imagemagick: graphic library (one graphic library is required)
+ optdepends = exiftool: Write Metadata plugin or any other plugin dealing with EXIF/IPTC metadata
+ optdepends = ffmpeg: VideoJS plugin to create video poster
+ optdepends = jpegtran: RotateImage plugin to rotate images with no compression
+ optdepends = pdftoppm: generate poster from PDF files (instead of ImageMagick)
options = emptydirs
backup = etc/webapps/piwigo/apache.conf
source = piwigo.zip::https://piwigo.org/download/dlcounter.php?code=latest
diff --git a/PKGBUILD b/PKGBUILD
index f82b78e130f8..7f6213225a91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,17 @@
pkgname=piwigo
pkgver=11.5.0
-pkgrel=2
+pkgrel=3
pkgdesc='Photo gallery software for the web'
arch=(any)
url="https://piwigo.org/"
license=("GPL")
-optdepends=('php-apache: to use the Apache web server')
-depends=("php" "php-gd" "mariadb")
+depends=('php' 'mariadb' 'php-apache')
+optdepends=('php-gd: graphic library (one graphic library is required)'
+ 'imagemagick: graphic library (one graphic library is required)'
+ 'exiftool: Write Metadata plugin or any other plugin dealing with EXIF/IPTC metadata'
+ 'ffmpeg: VideoJS plugin to create video poster'
+ 'jpegtran: RotateImage plugin to rotate images with no compression'
+ 'pdftoppm: generate poster from PDF files (instead of ImageMagick)')
makedepends=("unzip")
backup=("etc/webapps/piwigo/apache.conf")
options=(emptydirs)
@@ -17,13 +22,6 @@ sha256sums=('bfecdd743c62cdb4e1936662178d019af264ea763d26c8c832da836fbe09652d'
'5810668c0f9e7066a2f63e2c6b6fb5d13b7caa96fed16c882f6da2e7a6766219'
'0e6d4af6552f4eead62825999eee115152cf5f884f2c65b759379ac5b15d36f7')
-pkgver() {
-# curl -Is https://github.com/Piwigo/Piwigo/releases/latest | awk -F'/' '/^Location/ {print $NF}' | sed 's/[^[:print:]]//'
- curl -s https://piwigo.org/download/all_versions.php | head -1
-}
-
-
-
package() {
install_path="${pkgdir}/usr/share/webapps/piwigo"