summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShuyuan Liu2022-04-03 00:50:13 +0100
committerShuyuan Liu2022-04-03 00:50:13 +0100
commitac43de7815273379e78d1440ef9ee05775def647 (patch)
treeba91a877279e87280813cd376ad821b99a78567e
downloadaur-ac43de7815273379e78d1440ef9ee05775def647.tar.gz
First commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d45cd56965c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = pixd
+ pkgdesc = Colourful visualization tool for binary files
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/FireyFly/pixd
+ arch = x86_64
+ license = MIT
+ source = pixd-1.0.0.tar.gz::https://github.com/FireyFly/pixd/archive/refs/tags/v1.0.0.tar.gz
+ sha1sums = 55df5a553a9a9e4a3d726bcfa255ea6c3a47fb11
+
+pkgname = pixd
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..358eeb091238
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Shuyuan Liu <liu_shuyuan at qq dot com>
+
+pkgname=pixd
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Colourful visualization tool for binary files'
+arch=('x86_64')
+url='https://github.com/FireyFly/pixd'
+license=('MIT')
+
+depends=()
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/FireyFly/pixd/archive/refs/tags/v${pkgver}.tar.gz")
+sha1sums=('55df5a553a9a9e4a3d726bcfa255ea6c3a47fb11')
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}