summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScore_Under2022-12-11 09:51:56 +0000
committerScore_Under2022-12-11 09:51:56 +0000
commit4d873515b2a097508b49f3b86ff24c85a4fdd2bb (patch)
treeabc1eb89c43929760410827b9707149f09c0a20b
parent5149c84f5c84bc29e6ca2fdc4ad4c3784fbc6f60 (diff)
downloadaur-4d873515b2a097508b49f3b86ff24c85a4fdd2bb.tar.gz
Update upstream URL to avoid removed github git:// protocol
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8fb7d0f6aa3..a3f4b7309ede 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pixelscale-git
pkgdesc = Standalone xBR/HQx pixel art scaling library and standalone executable (includes hqx compatibility script, pixelscale binary and xbr script)
pkgver = 4.3835e97
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Treeki/libxbr-standalone
arch = x86_64
arch = i686
@@ -13,10 +13,9 @@ pkgbase = pixelscale-git
conflicts = hqx
source = hqx.sh
source = xbr.sh
- source = git://github.com/Treeki/libxbr-standalone.git
+ source = git+https://github.com/Treeki/libxbr-standalone.git
md5sums = 3d7095c7fb078367db0ad7716e06020d
md5sums = c28688c5c174f7852aabd5c51f7504c9
md5sums = SKIP
pkgname = pixelscale-git
-
diff --git a/PKGBUILD b/PKGBUILD
index baba040530ff..609215bd8f63 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: gandalf3 <zzyxpaw at gmail dot com>
+# Maintainer: Score_Under <seejay.11@gmail.com>
+# Contributor: gandalf3 <zzyxpaw at gmail dot com>
pkgname=pixelscale-git
_pkgname=libxbr-standalone
pkgver=4.3835e97
-pkgrel=3
+pkgrel=4
pkgdesc="Standalone xBR/HQx pixel art scaling library and standalone executable (includes hqx compatibility script, pixelscale binary and xbr script)"
url="https://github.com/Treeki/libxbr-standalone"
arch=('x86_64' 'i686')
@@ -12,7 +13,7 @@ depends=('libpng' 'imagemagick' )
makedepends=()
conflicts=('hqx')
provides=('hqx' 'xbr')
-source=('hqx.sh' 'xbr.sh' 'git://github.com/Treeki/libxbr-standalone.git')
+source=('hqx.sh' 'xbr.sh' "git+$url.git")
md5sums=('3d7095c7fb078367db0ad7716e06020d'
'c28688c5c174f7852aabd5c51f7504c9'
'SKIP')
@@ -34,7 +35,7 @@ build() {
msg2 "Compiling binary"
cc -Wall -Wno-parentheses -L. -lhq2x -lhq3x -lhq4x -lxbr -lpng test_app.c -o pixelscale
}
-
+
pkgver () {
cd "${srcdir}/$_pkgname"
echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"