summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzatherz2016-03-19 22:24:04 +0100
committerzatherz2016-03-19 22:24:04 +0100
commitf58b13490a2a4a96fc6e590722be5038558be031 (patch)
treebe95cbe8b6a27e5ab41592ddaef43af3bc2c4582
parentbbffc249a63ac14f488549c86b8f9bf8eba8273b (diff)
downloadaur-f58b13490a2a4a96fc6e590722be5038558be031.tar.gz
Fix hqx and xbr scripts to check for incorrect scale
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xhqx.sh3
-rwxr-xr-xxbr.sh3
4 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 335c6e5a94c0..8f517c17f005 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pixelscale-git
pkgdesc = Standalone xBR/HQx pixel art scaling library and standalone executable (includes hqx compatibility script, pixelscale binary and xbr script)
pkgver = 4.3835e97
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Treeki/libxbr-standalone
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index cd5750bd17f7..0f0fe944a989 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=pixelscale-git
_pkgname=libxbr-standalone
pkgver=4.3835e97
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone xBR/HQx pixel art scaling library and standalone executable (includes hqx compatibility script, pixelscale binary and xbr script)"
url="https://github.com/Treeki/libxbr-standalone"
arch=('x86_64' 'i686')
diff --git a/hqx.sh b/hqx.sh
index 1427befb2e7d..18baa9d8ad01 100755
--- a/hqx.sh
+++ b/hqx.sh
@@ -9,10 +9,11 @@ scale=4
while getopts ":s:" option; do
case $option in
s)
+ scale="$OPTARG"
if [ "$scale" -ne 2 ] && [ "$scale" -ne 3 ] && [ "$scale" -ne 4 ]; then
echo "Only scale factors of 2, 3 and 4 are supported"
+ exit 1
fi
- scale="$OPTARG"
;;
\?)
echo "Invalid option: -$OPTARG" >&2
diff --git a/xbr.sh b/xbr.sh
index 6a4045874401..f69a0c2ecff4 100755
--- a/xbr.sh
+++ b/xbr.sh
@@ -9,10 +9,11 @@ scale=4
while getopts ":s:" option; do
case $option in
s)
+ scale="$OPTARG"
if [ "$scale" -ne 2 ] && [ "$scale" -ne 3 ] && [ "$scale" -ne 4 ]; then
echo "Only scale factors of 2, 3 and 4 are supported"
+ exit 1
fi
- scale="$OPTARG"
;;
\?)
echo "Invalid option: -$OPTARG" >&2