summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzargbell2017-02-18 00:15:39 +0200
committerzargbell2017-02-18 00:15:39 +0200
commitfdb3faab69fb15435305dcffbe45a51b11ba69ab (patch)
tree4390cfd05d1d820829ab185b4eca97ca31da57b7
parentbb40021b975c8df958bccc0db2f757f0fa2b62e5 (diff)
downloadaur-fdb3faab69fb15435305dcffbe45a51b11ba69ab.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3356e279bb8c..fd6dd36f8a35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Dec 28 21:39:21 UTC 2016
+# Fri Feb 17 22:01:34 UTC 2017
pkgbase = pixiecore
pkgdesc = An all-in-one tool for easy netbooting
- pkgver = 16.12.24.1326
+ pkgver = 17.02.01.0153
pkgrel = 1
url = https://github.com/google/netboot/tree/master/pixiecore
arch = i686
@@ -11,6 +11,8 @@ pkgbase = pixiecore
license = GPL2
makedepends = go
makedepends = git
+ makedepends = curl
+ makedepends = jq
pkgname = pixiecore
diff --git a/PKGBUILD b/PKGBUILD
index ff44b7e2ef53..7d63bbe58884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zargbell <zargbell@yandex.ru>
pkgname=pixiecore
-pkgver=16.12.24.1326
+pkgver=17.02.01.0153
pkgrel=1
epoch=
pkgdesc="An all-in-one tool for easy netbooting"
@@ -10,7 +10,7 @@ url="https://github.com/google/netboot/tree/master/pixiecore"
license=('GPL2')
groups=()
depends=()
-makedepends=('go' 'git')
+makedepends=('go' 'git' 'curl' 'jq')
checkdepends=()
optdepends=()
provides=()
@@ -34,12 +34,27 @@ prepare() {
mkdir -p $GOBIN
go env
+
+ gopkgFR="$(git config --global http.https://gopkg.in.followRedirects || true)"
+
+ git config --global http.https://gopkg.in.followRedirects true
+}
+
+pkgver(){
+ # date last comment
+ curl -s 'https://api.github.com/repos/google/netboot/commits?per_page=1' | jq -c -r '.[].commit.committer.date | fromdate | strftime("%y.%m.%d.%H%M")'
}
build() {
go get -v go.universe.tf/netboot/cmd/pixiecore
+
+ case "${gopkgFR}" in
+ "" ) git config --global --unset http.https://gopkg.in.followRedirects;;
+ * ) git config --global http.https://gopkg.in.followRedirects "${gopkgFR}";;
+ esac
}
+
package() {
install -Dm755 "$GOBIN/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}