summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortake100yen2019-07-18 16:41:05 +0900
committertake100yen2019-07-18 16:41:05 +0900
commit7c8b4998f349008741dfd9136498c533fed89290 (patch)
treee1d0932992a189349be6ca28eb5d8162e48f3f32
downloadaur-7c8b4998f349008741dfd9136498c533fed89290.tar.gz
Initial
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
-rw-r--r--license21
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5dfc6ba92a60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pixivdeck-bin
+ pkgdesc = pixiv client for Desktop like TweetDeck
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/akameco/PixivDeck
+ arch = x86_64
+ license = MIT
+ depends = electron
+ provides = pixivdeck
+ conflicts = pixivdeck
+ source = https://github.com/akameco/PixivDeck/releases/download/v1.4.0/PixivDeck_1.4.0_amd64.deb
+ source = license
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = pixivdeck-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a537fe9bdac7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+pkgname=pixivdeck-bin
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="pixiv client for Desktop like TweetDeck"
+arch=("x86_64")
+url="https://github.com/akameco/PixivDeck"
+license=("MIT")
+depends=("electron")
+provides=("pixivdeck")
+conflicts=("pixivdeck")
+source=("https://github.com/akameco/PixivDeck/releases/download/v$pkgver/PixivDeck_${pkgver}_amd64.deb" "license")
+md5sums=("SKIP" "SKIP")
+
+package(){
+tar xf data.tar.xz -C "${pkgdir}"
+mkdir $pkgdir/usr/bin
+ln -sf ${pkgdir}"/opt/PixivDeck/pixivdeck" $pkgdir"/usr/bin/pixivdeck"
+mkdir -p $pkgdir/usr/share/licenses/pixivdeck-bin/
+cp license $pkgdir/usr/share/licenses/pixivdeck-bin/license
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..4e748e8eb1e6
--- /dev/null
+++ b/license
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) akameco <akameco.t@gmail.com> (akameco.github.io)
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.