summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenton Liu2023-12-16 19:38:12 -0800
committerDenton Liu2023-12-16 19:38:12 -0800
commitc2a7df61c067b26787992d99ace21d5bea92e441 (patch)
tree6c7bdd85427bf9965b9ef28c92a6f3d2b50334c5
downloadaur-pixlet.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2670b5585e81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pixlet
+ pkgdesc = Build apps for pixel-based displays
+ pkgver = 0.29.1
+ pkgrel = 1
+ url = https://github.com/tidbyt/pixlet
+ arch = x86_64
+ arch = aarch64
+ license = Apache
+ makedepends = npm
+ makedepends = go
+ depends = libwebp
+ source = https://github.com/tidbyt/pixlet/archive/v0.29.1.tar.gz
+ sha256sums = 8a96ac31b74263b6ef31ebdfe63b8061fabab5d498b9612b560982810a47d4f3
+
+pkgname = pixlet
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e4bbed394a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Denton Liu <liu.denton@gmail.com>
+pkgname=pixlet
+pkgver=0.29.1
+pkgrel=1
+pkgdesc='Build apps for pixel-based displays'
+arch=('x86_64' 'aarch64')
+url='https://github.com/tidbyt/pixlet'
+license=('Apache')
+depends=('libwebp')
+makedepends=('npm' 'go')
+source=("https://github.com/tidbyt/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('8a96ac31b74263b6ef31ebdfe63b8061fabab5d498b9612b560982810a47d4f3')
+
+build () {
+ cd "$pkgname-$pkgver"
+ npm install
+ npm run build
+ make build
+}
+
+package () {
+ cd "$pkgname-$pkgver"
+ install -Dm755 pixlet "$pkgdir"/usr/bin/pixlet
+}