summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Reuße2017-02-11 12:41:07 +0100
committerSebastian Reuße2017-02-11 12:41:07 +0100
commit6569c64d2a8765cf8f137d4f0abf6cf72f5c8cc1 (patch)
tree21bb702bf437176c49ec68dd398254370cb919d6
downloadaur-6569c64d2a8765cf8f137d4f0abf6cf72f5c8cc1.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f437e6493310
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Feb 11 11:41:07 UTC 2017
+pkgbase = pixterm-git
+ pkgdesc = Draw images in your ANSI terminal with true color
+ pkgver = r9.0604f32
+ pkgrel = 1
+ url = https://github.com/eliukblau/pixterm
+ arch = x86_64
+ arch = i686
+ license = MPL
+ makedepends = git
+ makedepends = go
+ provides = pixterm
+ conflicts = pixterm
+ source = git+https://github.com/eliukblau/pixterm
+ md5sums = SKIP
+
+pkgname = pixterm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..468cd87d3ce8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ac20ee634f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Sebastian Reuße <seb@wirrsal.net>
+pkgname=pixterm-git
+_gitname=pixterm
+pkgver=r9.0604f32
+pkgrel=1
+pkgdesc="Draw images in your ANSI terminal with true color"
+arch=(x86_64 i686)
+url=https://github.com/eliukblau/pixterm
+license=(MPL)
+makedepends=(git go)
+provides=(pixterm)
+conflicts=(pixterm)
+source=(git+https://github.com/eliukblau/pixterm)
+md5sums=(SKIP)
+
+
+pkgver() {
+ cd "$_gitname"
+ # No tagged commits. ヽ(´ー`)ノ
+ commit=$(git rev-list --count master)
+ hash=$(git rev-parse --short HEAD)
+ echo "r$commit.$hash"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ export GOPATH="$srcdir/gopath"
+ [ -d "$GOPATH" ] || mkdir "$srcdir"/gopath
+ go get -d
+ go build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm755 pixterm "$pkgdir/usr/bin/pixterm"
+}