summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThiago Coutinho2015-06-19 09:08:43 -0300
committerThiago Coutinho2015-06-19 09:08:43 -0300
commita29213f923a87ab8b4338bd94ab375e36ccb1fbb (patch)
tree4418bcca3c65d002d1eff68f55e978723fa06fcb
downloadaur-a29213f923a87ab8b4338bd94ab375e36ccb1fbb.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c4f49b35d83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pjsua
+ pkgdesc = Open source command line SIP user agent
+ pkgver = 2.4
+ pkgrel = 1
+ url = http://www.pjsip.org/pjsua.htm
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ffmpeg
+ source = http://www.pjsip.org/release/2.4/pjproject-2.4.tar.bz2
+ md5sums = 39629ca3fcedbdc7dbd8c5a707060095
+
+pkgname = pjsua
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f18e647b904
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thiago Coutinho <root thiagoc net>
+# Contributor: Marti Raudsepp <marti@juffo.org>
+# Contributor: Sonny Piers <sonny <AT> fastmail <DOT> net>
+# Submitter: sputnick <gilles.quenot <AT> gmail <DOT> com>
+
+pkgname=pjsua
+pkgver=2.4
+pkgrel=1
+pkgdesc="Open source command line SIP user agent"
+arch=(i686 x86_64)
+url="http://www.pjsip.org/pjsua.htm"
+depends=(ffmpeg)
+license=('GPL')
+source=(http://www.pjsip.org/release/$pkgver/pjproject-$pkgver.tar.bz2)
+
+build() {
+ cd $srcdir/pjproject-$pkgver
+ # make -j breaks the build
+ export MAKEFLAGS=
+ ./configure --prefix=/usr
+ #make dep
+ make
+}
+package() {
+ cd $srcdir/pjproject-$pkgver
+ make DESTDIR=$pkgdir install
+ install -D -m755 pjsip-apps/bin/pjsua-*gnu $pkgdir/usr/bin/pjsua
+}
+md5sums=('39629ca3fcedbdc7dbd8c5a707060095')