summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2016-09-08 10:51:45 +0200
committerMarco Pompili2016-09-08 10:51:45 +0200
commit39b466888834ad204dbec212213f8704971c6a91 (patch)
tree83e7c1e026c05d3770309840f6f6c6d19b83cd0c
parent921d75d8afa4e052f94a34f3100dc477caee1f1c (diff)
downloadaur-39b466888834ad204dbec212213f8704971c6a91.tar.gz
Version 1.2.2-3, Add custom LICENSE and .install
-rw-r--r--.SRCINFO7
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD29
-rw-r--r--pkcrack.install10
4 files changed, 48 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c71987d9cb67..8c14e6c5d937 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
# Generated by mksrcinfo v8
-# Tue Sep 6 13:43:06 UTC 2016
+# Thu Sep 8 08:37:29 UTC 2016
pkgbase = pkcrack
pkgdesc = An algorithm for breaking the PkZip cipher that was devised by Eli Biham and Paul Kocher.
pkgver = 1.2.2
- pkgrel = 2
+ pkgrel = 3
url = https://www.unix-ag.uni-kl.de/~conrad/krypto/pkcrack.html
+ install = pkcrack.install
arch = i686
arch = x86_64
license = custom
depends = glibc
source = https://www.unix-ag.uni-kl.de/~conrad/krypto/pkcrack/pkcrack-1.2.2.tar.gz
+ source = LICENSE
sha256sums = 4d2dc193ffa4342ac2ed3a6311fdf770ae6a0771226b3ef453dca8d03e43895a
+ sha256sums = c7243221bf8692cef82dadcf4db0e2c64a845b2373eb8b5827e8db512a0e4e84
pkgname = pkcrack
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d60242a2a482
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,13 @@
+LICENSE and Copyright
+=====================
+
+This package was written and is copyright by
+Peter Conrad <conrad@unix-ag.uni-kl.de>.
+
+Commercial use in any form is strictly forbidden!
+
+You may use parts of the code in your own programs for non-commercial use
+in case you clearly state where you got it.
+
+Do not release software using parts of the code without the author's
+explicit consent.
diff --git a/PKGBUILD b/PKGBUILD
index 791a3ed1cf44..f3c7641183b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,17 @@
pkgname=pkcrack
pkgver=1.2.2
-pkgrel=2
+pkgrel=3
pkgdesc="An algorithm for breaking the PkZip cipher that was devised by Eli Biham and Paul Kocher."
arch=('i686' 'x86_64')
url="https://www.unix-ag.uni-kl.de/~conrad/krypto/pkcrack.html"
license=('custom')
depends=('glibc')
-source=("https://www.unix-ag.uni-kl.de/~conrad/krypto/pkcrack/pkcrack-${pkgver}.tar.gz")
-sha256sums=('4d2dc193ffa4342ac2ed3a6311fdf770ae6a0771226b3ef453dca8d03e43895a')
+source=("https://www.unix-ag.uni-kl.de/~conrad/krypto/pkcrack/pkcrack-${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=('4d2dc193ffa4342ac2ed3a6311fdf770ae6a0771226b3ef453dca8d03e43895a'
+ 'c7243221bf8692cef82dadcf4db0e2c64a845b2373eb8b5827e8db512a0e4e84')
+install=pkcrack.install
build() {
cd ${pkgname}-${pkgver}/src
@@ -17,10 +20,18 @@ build() {
}
package() {
- cd ${pkgname}-${pkgver}/src
- install -Dm755 extract ${pkgdir}/usr/bin/extract
- install -Dm755 findkey ${pkgdir}/usr/bin/findkey
- install -Dm755 makekey ${pkgdir}/usr/bin/makekey
- install -Dm755 pkcrack ${pkgdir}/usr/bin/pkcrack
- install -Dm755 zipdecrypt ${pkgdir}/usr/bin/zipdecrypt
+ # license
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+
+ # bin
+ cd ${pkgname}-${pkgver}
+ install -Dm755 src/extract ${pkgdir}/usr/bin/extract
+ install -Dm755 src/findkey ${pkgdir}/usr/bin/findkey
+ install -Dm755 src/makekey ${pkgdir}/usr/bin/makekey
+ install -Dm755 src/pkcrack ${pkgdir}/usr/bin/pkcrack
+ install -Dm755 src/zipdecrypt ${pkgdir}/usr/bin/zipdecrypt
+
+ # doc
+ install -d ${pkgdir}/usr/share/doc
+ cp -R doc ${pkgdir}/usr/share/doc/pkcrack
}
diff --git a/pkcrack.install b/pkcrack.install
new file mode 100644
index 000000000000..3d375eb3f73a
--- /dev/null
+++ b/pkcrack.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo -e "\n"
+ cat /usr/share/licenses/pkcrack/LICENSE
+}
+
+post_upgrade() {
+ post_install
+ echo -e "\nChanges\n=======\n"
+ cat /usr/share/doc/pkcrack/CHANGES
+} \ No newline at end of file