summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-12 22:23:09 +0800
committerChocobo12023-04-12 22:23:09 +0800
commit44349466dd2e87059b3b79c17a2dcfac7f5ca7d2 (patch)
treeecd798d85bc0cc16a2127ec6be3624ea95e74407
parentab17c9e598ca7e28bce2e7a6264f0f38680d8529 (diff)
downloadaur-44349466dd2e87059b3b79c17a2dcfac7f5ca7d2.tar.gz
upgpkg: pkg-config-git 0.29.2.r1.g2dd2b19-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ee2a753a1f7..c45e3244debc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pkg-config-git
pkgdesc = A system for managing library compile/link flags
pkgver = 0.29.2.r1.g2dd2b19
- pkgrel = 2
+ pkgrel = 3
url = https://www.freedesktop.org/wiki/Software/pkg-config/
arch = i686
arch = x86_64
@@ -9,7 +9,9 @@ pkgbase = pkg-config-git
makedepends = git
depends = glibc
depends = glib2
+ provides = pkg-config=0.29.2.r1.g2dd2b19
provides = pkgconfig
+ conflicts = pkg-config
conflicts = pkgconfig
source = git+https://anongit.freedesktop.org/git/pkg-config.git
source = 0001-Workaround-error-m4_copy.patch
@@ -17,4 +19,3 @@ pkgbase = pkg-config-git
sha256sums = 03e1c1a997590b82c0922fca86c7be5ee85d04181c6f2ce020bdbe53c7f1b47b
pkgname = pkg-config-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c663b0400b1f..59ecbb8d0ccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=pkg-config-git
pkgver=0.29.2.r1.g2dd2b19
-pkgrel=2
+pkgrel=3
pkgdesc="A system for managing library compile/link flags"
arch=('i686' 'x86_64')
url="https://www.freedesktop.org/wiki/Software/pkg-config/"
license=('GPL2')
depends=('glibc' 'glib2')
makedepends=('git')
-provides=('pkgconfig')
-conflicts=('pkgconfig')
+provides=("pkg-config=$pkgver" 'pkgconfig')
+conflicts=('pkg-config' 'pkgconfig')
source=("git+https://anongit.freedesktop.org/git/pkg-config.git"
"0001-Workaround-error-m4_copy.patch")
sha256sums=('SKIP'
@@ -32,8 +32,10 @@ pkgver() {
build() {
cd "pkg-config"
- ./autogen.sh --no-configure
- ./configure --prefix="/usr"
+ ./autogen.sh \
+ --no-configure
+ ./configure \
+ --prefix="/usr"
make
}