summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2024-04-12 03:40:13 +0000
committerGitHub Action2024-04-12 03:40:13 +0000
commitb7e99007d57e66c855855b13b45d0d0295d07297 (patch)
tree4e3c65ac48e93aeb8c2186d6b371b1d8f5bff450
downloadaur-b7e99007d57e66c855855b13b45d0d0295d07297.tar.gz
Update from GitHub Actions: pkg.sh-git: init at 0.2.0.r0.g4d4c643
https://github.com/RiverOnVenus/AUR-packages/actions/runs/8656618153
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11419ee4ae0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pkg.sh-git
+ pkgdesc = A generalized package manager for whatever code
+ pkgver = 0.2.0.r0.g4d4c643
+ pkgrel = 1
+ url = https://github.com/tidwall/pkg.sh
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = pkg.sh
+ conflicts = pkg.sh
+ source = pkg.sh-git::git+https://github.com/tidwall/pkg.sh
+ sha256sums = SKIP
+
+pkgname = pkg.sh-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89c2c42ca329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: RiverOnVenus <error@zhui.dev>
+pkgname=pkg.sh-git
+pkgver=0.2.0.r0.g4d4c643
+pkgrel=1
+pkgdesc="A generalized package manager for whatever code"
+arch=(any)
+url="https://github.com/tidwall/pkg.sh"
+license=('MIT')
+provides=('pkg.sh')
+conflicts=('pkg.sh')
+makedepends=('git')
+source=("$pkgname"::"git+${url}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 pkg.sh "$pkgdir/usr/bin/pkg.sh"
+}