summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevertonstz2019-11-06 19:57:43 -0300
committerevertonstz2019-11-06 19:57:43 -0300
commit11db2b4c19f8196b7e7232e99dd28f3b2bf76c5a (patch)
tree8acb129726f40de0ea89da851eb5b9e26bf0c6f1
downloadaur-11db2b4c19f8196b7e7232e99dd28f3b2bf76c5a.tar.gz
publishing
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08ea6defa673
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pkg2zip
+ pkgdesc = This is for lusid1's fork, recomended by NoPayStation. Decrypts PlayStation Vita pkg file and packages to zip archive
+ pkgver = 2.2
+ pkgrel = 1
+ url = https://github.com/lusid1/pkg2zip
+ arch = i686
+ arch = x86_64
+ license = custom:unlicense
+ source = https://github.com/lusid1/pkg2zip/archive/2.2.tar.gz
+ sha256sums = f2a347448324a027edf02cf80dee695394bfcb73298203fd355f0e33e014989b
+
+pkgname = pkg2zip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c6daf093ca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Martins Mozeiko <martins.mozeiko@gmail.com>
+
+pkgname=pkg2zip
+pkgver=2.2
+pkgrel=1
+pkgdesc="This is for lusid1's fork, recomended by NoPayStation. Decrypts PlayStation Vita pkg file and packages to zip archive"
+url='https://github.com/lusid1/pkg2zip'
+arch=('i686' 'x86_64')
+license=('custom:unlicense')
+source=("https://github.com/lusid1/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('f2a347448324a027edf02cf80dee695394bfcb73298203fd355f0e33e014989b')
+
+package() {
+
+ cd "${srcdir}"/"${pkgname}-${pkgver}"
+ make CFLAGS="-DNDEBUG -O2 -Wno-format-truncation"
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ install -Dm755 pkg2zip "${pkgdir}"/usr/bin/pkg2zip
+}