summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoar Heimonen2023-12-11 05:08:16 +0100
committerJoar Heimonen2023-12-11 05:08:16 +0100
commitc25d554f473a02fa2d6e19101d80870b48f142e9 (patch)
treea255033456a5d52c0f1b187f891ba9ab94f3cc67
parent027d84c4f279f8e6218501e6abc611e2e8110785 (diff)
downloadaur-c25d554f473a02fa2d6e19101d80870b48f142e9.tar.gz
Moved prepare into build
-rw-r--r--PKGBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9c24a31b622..7de12f408fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,25 +9,16 @@ arch=('x86_64')
url="https://github.com/vlvassilev/yuma123"
license=('BSD')
depends=('git' 'autoconf' 'automake' 'libtool' 'make' 'gcc')
-makedepends=()
+makedepends=('libtool') # Add libtool as a build dependency
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
pkgbase=yuma123-git
source=("git+https://github.com/vlvassilev/yuma123")
-prepare() {
- cd "$srcdir/yuma123"
- libtoolize
- #Move ltmain.sh from ../.. to .
- if [ -d ../.. ] && [ -n "$(find ../.. -maxdepth 1 -name '*.sh' -print -quit)" ]; then
- mv ../../*.sh .
- fi
- autoreconf -i -f
-}
-
build() {
cd "$srcdir/yuma123"
+ autoreconf -i -f
./configure CFLAGS='-g -O0' CXXFLAGS='-g -O0' --prefix=/usr
make
}
@@ -38,4 +29,5 @@ package() {
mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
}
+
sha256sums=('SKIP') \ No newline at end of file