summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2018-08-11 09:17:31 -0700
committerEric Anderson2018-08-11 09:17:31 -0700
commit921ae17720b737c1ca46d661d8ed13cabc090fc3 (patch)
treede17ac1bcdeb7bd595ceff1a699fa33a93568ccf
parentae8d75ee518a7bd10dfb18f8faa3a86a8d76a7ad (diff)
downloadaur-921ae17720b737c1ca46d661d8ed13cabc090fc3.tar.gz
Convert to explicit DBusGMainLoop
This fixes the warning: DeprecationWarning: Importing dbus.glib to use the GLib main loop with dbus-python is deprecated. Instead, use this sequence: from dbus.mainloop.glib import DBusGMainLoop DBusGMainLoop(set_as_default=True) import dbus.glib
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
-rwxr-xr-xpkgdistcache-client4
-rwxr-xr-xpkgdistcache-daemon4
4 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 946b8e874143..afb7f80e9568 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Tue Mar 20 02:20:50 UTC 2018
pkgbase = pkgdistcache
pkgdesc = A distributed local-network cache for pacman packages
- pkgver = 0.5.0
- pkgrel = 3
+ pkgver = 0.5.1
+ pkgrel = 1
url = http://venator.ath.cx/dw/doku.php?id=linux:pkgdistcache
install = pkgdistcache.install
arch = any
@@ -20,8 +18,8 @@ pkgbase = pkgdistcache
source = pkgdistcache-daemon
source = pkgdistcache.conf
source = pkgdistcached.service
- sha256sums = eac5e8c4afebdbb3b93d9d50d10abdaa3cdbd9da796d969f2cd9db2064a69d8d
- sha256sums = 10379b95265e7aa3c6334197ef255327281e35b958c3c062ae893dd3a646a66e
+ sha256sums = a84a9e36471090bf584721747baf2b2b49bacf1c32d8759c3d286bbb331a7f60
+ sha256sums = 6443de9081b7cf350cc261ac9d761bcdf17d01218f762ab85d747ea7eaf90a1d
sha256sums = 25106b1e2ed50d04a684f4d356f3d5a34c815fe77af486c863a292dc7643105f
sha256sums = b98bccb089bc0025b0f9b4b949b691e5564b0e40778a263a5bb6ffa5f01d04a2
diff --git a/PKGBUILD b/PKGBUILD
index 7419c020db56..6a7501926139 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=pkgdistcache
-pkgver=0.5.0
-pkgrel=3
+pkgver=0.5.1
+pkgrel=1
pkgdesc='A distributed local-network cache for pacman packages'
arch=('any')
url='http://venator.ath.cx/dw/doku.php?id=linux:pkgdistcache'
@@ -15,8 +15,8 @@ source=('pkgdistcache-client'
'pkgdistcache-daemon'
'pkgdistcache.conf'
'pkgdistcached.service')
-sha256sums=('eac5e8c4afebdbb3b93d9d50d10abdaa3cdbd9da796d969f2cd9db2064a69d8d'
- '10379b95265e7aa3c6334197ef255327281e35b958c3c062ae893dd3a646a66e'
+sha256sums=('a84a9e36471090bf584721747baf2b2b49bacf1c32d8759c3d286bbb331a7f60'
+ '6443de9081b7cf350cc261ac9d761bcdf17d01218f762ab85d747ea7eaf90a1d'
'25106b1e2ed50d04a684f4d356f3d5a34c815fe77af486c863a292dc7643105f'
'b98bccb089bc0025b0f9b4b949b691e5564b0e40778a263a5bb6ffa5f01d04a2')
diff --git a/pkgdistcache-client b/pkgdistcache-client
index dec92223daa2..8bc7d8ad6680 100755
--- a/pkgdistcache-client
+++ b/pkgdistcache-client
@@ -17,11 +17,13 @@ import time
import avahi
import dbus
-import dbus.glib
+from dbus.mainloop.glib import DBusGMainLoop
import requests
import xdg.BaseDirectory
from gi.repository import GLib
+DBusGMainLoop(set_as_default=True)
+
colors = {
'none': '\033[0m',
'black': '\033[0;30m', 'bold_black': '\033[1;30m',
diff --git a/pkgdistcache-daemon b/pkgdistcache-daemon
index 5d5b7899d8e8..6b911e174ca4 100755
--- a/pkgdistcache-daemon
+++ b/pkgdistcache-daemon
@@ -14,7 +14,9 @@ import sys
import avahi
import dbus
-import dbus.glib
+from dbus.mainloop.glib import DBusGMainLoop
+
+DBusGMainLoop(set_as_default=True)
avahi_service = None