summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2017-09-02 09:00:50 -0700
committerEric Anderson2017-09-02 09:00:50 -0700
commitbede6f0d9a225d918e9d37bb8f6b7f1361c2c13a (patch)
tree287853a9f56db118591523ddb7a3a6a5c514f36a
parent604aeb67e38064cc8690884c972103e4633485bd (diff)
downloadaur-bede6f0d9a225d918e9d37bb8f6b7f1361c2c13a.tar.gz
Bump to 0.4.2 for fixed TimeoutError exception handling
The Python exception type seems to be dbus.exceptions.DBusException (which has an alias at dbus.DBusException), and it is communicating the dbus-style exception with name org.freedesktop.Avahi.TimeoutError.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xpkgdistcache-client5
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efb361d4e0c0..5f4f624c2e64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Aug 5 22:16:22 UTC 2017
+# Sat Sep 2 16:00:18 UTC 2017
pkgbase = pkgdistcache
pkgdesc = A distributed local-network cache for pacman packages
- pkgver = 0.4.1
+ pkgver = 0.4.2
pkgrel = 1
url = http://venator.ath.cx/dw/doku.php?id=linux:pkgdistcache
install = pkgdistcache.install
@@ -17,7 +17,7 @@ pkgbase = pkgdistcache
source = pkgdistcache-daemon
source = pkgdistcache.conf
source = pkgdistcached.service
- sha256sums = a81002a48fc18f454cfadc013c06ed5ffe06ea7762fbf09517135b35b7503e46
+ sha256sums = 4b900e1c32162eeb51370998cec336d60e3201185f33258e2ce46dbbcf02f149
sha256sums = 8f298c9f1548b56373038fe69f8568dc77e17a700476594155359df20eb275a4
sha256sums = d77ac418aa651bc622cd91204d6907554c6cdb4bb989e484cc54da32342faa51
sha256sums = fdfa58e652230725a232de41c87627ed8c9a4fd9d081c8a3d261ea75cf91a81a
diff --git a/PKGBUILD b/PKGBUILD
index cef56dc1ab42..4af9abbce046 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=pkgdistcache
-pkgver=0.4.1
+pkgver=0.4.2
pkgrel=1
pkgdesc='A distributed local-network cache for pacman packages'
arch=('any')
@@ -14,7 +14,7 @@ source=('pkgdistcache-client'
'pkgdistcache-daemon'
'pkgdistcache.conf'
'pkgdistcached.service')
-sha256sums=('a81002a48fc18f454cfadc013c06ed5ffe06ea7762fbf09517135b35b7503e46'
+sha256sums=('4b900e1c32162eeb51370998cec336d60e3201185f33258e2ce46dbbcf02f149'
'8f298c9f1548b56373038fe69f8568dc77e17a700476594155359df20eb275a4'
'd77ac418aa651bc622cd91204d6907554c6cdb4bb989e484cc54da32342faa51'
'fdfa58e652230725a232de41c87627ed8c9a4fd9d081c8a3d261ea75cf91a81a')
diff --git a/pkgdistcache-client b/pkgdistcache-client
index 744f4bcb713c..75846eed0b90 100755
--- a/pkgdistcache-client
+++ b/pkgdistcache-client
@@ -99,8 +99,9 @@ class AvahiBrowser(object):
s = self.server.ResolveService(interface, protocol, name, stype, domain, avahi.PROTO_UNSPEC, dbus.UInt32(0))
service = Service(str(s[3]), str(s[2]), str(s[7]), int(s[8])) # service name, host, ip, port
self.services.append(service)
- except TimeoutError:
- printwarn("Timeout error during service resolution!")
+ except dbus.DBusException as ex:
+ # Mainly expect to see org.freedesktop.Avahi.TimeoutError: Timeout reached
+ printwarn(ex)
def all_for_now(self):
self.loop.quit()