summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2017-09-14 16:25:03 +0200
committerAlad Wenter2017-09-14 16:25:03 +0200
commitbc7f41674cb18bec89bbf4d237ed8e2f8a67d297 (patch)
tree548ead8ea5b0d79045600a0eea51ecb13486fb83
parentbfc41595edc45866f8ce2814e8ccc02b4e4db28c (diff)
downloadaur-pkgelf-git.tar.gz
pkgelf-git: add provides/conflicts
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da28596f3045..4d4ce89bb52d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Sun May 1 09:28:48 UTC 2016
+# Thu Sep 14 14:25:01 UTC 2017
pkgbase = pkgelf-git
pkgdesc = alpm package bintools
pkgver = r48.8428984
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vodik/pkgelf
arch = i686
arch = x86_64
license = GPL
makedepends = git
depends = pacman
+ provides = pkgelf
+ conflicts = pkgelf
source = pkgelf-git::git+https://github.com/vodik/pkgelf
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index abe26e820992..224722aca56d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
# Maintainer: Alad Wenter <nynq@nepuyvahk.vasb> (rot13)
pkgname=pkgelf-git
pkgver=r48.8428984
-pkgrel=1
+pkgrel=2
pkgdesc="alpm package bintools"
arch=('i686' 'x86_64')
url="https://github.com/vodik/pkgelf"
license=('GPL')
depends=('pacman')
makedepends=('git')
+conflicts=('pkgelf')
+provides=('pkgelf')
source=("$pkgname::git+$url")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$pkgname"
- make
+ cd "$pkgname"
+ make
}
package() {
- cd "$pkgname"
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
}