summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbuckket2019-04-14 16:59:14 +0200
committerbuckket2019-04-14 16:59:14 +0200
commit2ab355b32f827b6407db1cca1d89636aa7f89b50 (patch)
tree4ad083a8e44d66bab2d2816c9d4b63a1f6539eb1
downloadaur-2ab355b32f827b6407db1cca1d89636aa7f89b50.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--pkgproxy.service10
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca3ebd4a48f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pkgproxy
+ pkgdesc = pkgproxy is a caching proxy server for usage with pacman
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/buckket/pkgproxy
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = go-pie
+ source = https://github.com/buckket/pkgproxy/archive/v1.0.0.tar.gz
+ source = pkgproxy.service
+ sha256sums = 3a166f13815d8e47ed771678da2cf060232134478683540fadbe98007467a095
+ sha256sums = 2c8ca0036aa5dd42d66605cb3a9e02abd33500840be5536579b522592881e7fb
+
+pkgname = pkgproxy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..78ebed2076f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: buckket <felix@buckket.org>
+
+pkgname=pkgproxy
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='pkgproxy is a caching proxy server for usage with pacman'
+arch=('x86_64' 'i686')
+url="https://github.com/buckket/$pkgname"
+license=('GPL')
+makedepends=('go-pie')
+source=("$url/archive/v$pkgver.tar.gz" "pkgproxy.service")
+sha256sums=('3a166f13815d8e47ed771678da2cf060232134478683540fadbe98007467a095'
+ '2c8ca0036aa5dd42d66605cb3a9e02abd33500840be5536579b522592881e7fb')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ install -Dm755 $pkgname "${pkgdir}"/usr/bin/${pkgname}
+ install -Dm644 -t "${pkgdir}"/usr/lib/systemd/user ../pkgproxy.service
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/pkgproxy.service b/pkgproxy.service
new file mode 100644
index 000000000000..59090c827c1d
--- /dev/null
+++ b/pkgproxy.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=pkgproxy
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/pkgproxy
+
+[Install]
+WantedBy=default.target
+